Modify

Opened 12 years ago

Closed 12 years ago

#3967 closed defect (worksforme)

Relation editor generates conflicts

Reported by: Nakor Owned by: team
Priority: critical Milestone:
Component: Core Version: latest
Keywords: Cc: dkick, kay_D

Description

The following scenario works fine in 2454 but is broken in 2466

With the remote plugin get http://localhost:8111/import?url=http://api.openstreetmap.org/api/0.6/relation/255174

Open the relation editor and download all members.
Delete any members and click OK.

FIRST ISSUE: a conflict is created because the relation was supposedly modified outside the editor.

Accept the conflict
Try to resolve the conflict

SECOND ISSUE: my version still have the member that I just deleted

Accept their version (with one member removed) and close the conflict resolution

Try to upload

THIRD ISUUE: JOSM pretends there is nothing to upload

Attachments (1)

BLUS127.osm (34.8 KB) - added by Nakor 12 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 12 years ago by anonymous

Same bug in 2468.

comment:2 Changed 12 years ago by anonymous

Any change on a relation is not working any longer (also working on 2468).
When commiting the change (OK click) you always get the error popup:

Relation was changed outside the editor...

regards

peter

comment:3 in reply to:  2 Changed 12 years ago by anonymous

Replying to anonymous:

Any change on a relation is not working any longer (also working on 2468).

I've better written: I am also working on 2468 at the moment.

comment:4 Changed 12 years ago by dkick

Cc: dkick added
Version: latest

comment:5 Changed 12 years ago by Gubaer

I can't reproduce. If I download http://api.openstreetmap.org/api/0.6/relation/255174 with "File->Open location" , edit the relation and click "OK" everything is fine.

If I edit any other relation or if I create a new relation everything is fine.

Is t his only happening when the relation is loaded through the remotecontrol plugin?

comment:6 Changed 12 years ago by kay_D

Cc: kay_D added

Can be easily reproduces here (2466):

Just download *any* area (that contains a relation). Open the relation editor with any relation.
Edit anything in the relation editor, e.g. change or add a "name" tag. Try to exit the relation editor - it will come up with the error message "Relation was changed outside the editor" (in German, for me).

comment:7 Changed 12 years ago by Gubaer

Confirmed, very easy to reproduce. Don't know why I didn't run into it three hours earlier.

comment:8 Changed 12 years ago by stoecker

Resolution: fixed
Status: newclosed

In r2481.

comment:9 Changed 12 years ago by anonymous

Ticket #3986 has been marked as a duplicate of this ticket.

comment:10 Changed 12 years ago by Nakor

Resolution: fixed
Status: closedreopened

I found a situation where it happens in 2481:

Open attached file and modifiy role of way 41286010 from none to south, the try to close the relation window.

Changed 12 years ago by Nakor

Attachment: BLUS127.osm added

comment:11 Changed 12 years ago by Gubaer

Resolution: worksforme
Status: reopenedclosed

Can't reproduce in r2486 with the data you've attached. Closing as worksforme.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.