Modify

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3881 closed defect (fixed)

Node icons aren't updated correctly when using undo

Reported by: anonymous Owned by: team
Priority: major Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

When undoing a change to a node that affected the icon shown for the node on the map view, the icon stays the same after undo.

Even when a node is created, and then eg. amenity=bus_stop is added, and both are undoed, and then only the creation is redoed, the icon is still bus_stop, even though the node doesn't have the tag.

Attachments (0)

Change History (2)

comment:1 Changed 12 years ago by stoecker

Resolution: fixed
Status: newclosed

(In [2459]) fix #3881 - paintstyle caching broken for Undo

comment:2 Changed 12 years ago by stoecker

Ticket #3732 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.