Modify

Opened 8 years ago

Last modified 7 years ago

#3831 reopened enhancement

conflict management too complicated and misleading

Reported by: dieterdreist Owned by: team
Priority: major Milestone:
Component: Core Version:
Keywords: conflict, upload Cc:

Description

it's been some time that I have been using conflict management, but it seems that current state is somehow broken.

  1. I edited a way by adding oneway-property and deleted "created by potlatch"-tag
  2. downloaded the same area. I got a conflict, where my version of "created by" was "<undefined><undefined>" (because I deleted the tag, but could be something more vocal like "tag deleted") I wonder why I got into conflict management, as there should be normally no conflict (afaik nobody else edited the same area in these 4 minutes)

additionally there was an almost cryptical window for resolving node conflicts. I get lots of node-numbers and should arrange them into an order (as far as I understood it). But orders are just for ways, not for nodes? The window was screwed up, so I could read all of it (even on resize, please see screenshot).

Attachments (1)

conflict_management.png (75.7 KB) - added by dieterdreist 8 years ago.

Download all attachments as: .zip

Change History (9)

Changed 8 years ago by dieterdreist

Attachment: conflict_management.png added

comment:1 Changed 8 years ago by Gubaer

Can't reproduce.

I downloaded the Via dell'Elettronica (within zoom level 16), removed created_by, added oneway=yes.

  • Downloaded again - everything is fine, no conflicts.
  • Updated data - everything is fine, no conflicts.
  • Only updated Via dell'Elettronica - everything is fine - no conflict.

But orders are just for ways, not for nodes?

Yes, Via dell'Elettronica is a way, isn't it?

Something in your local dataset looks strange. Your Via dell'Elettronica has four nodes, but the server version never has more than three.

And Via dell'Elettronica you got from the server seems to have two nodes, but the latest version on the server has three.

Did you notice the Help button in the dialog? There? you can find a description on how to resolve conflicts in the list of nodes of a way.

BTW: what JOSM version are you working with?

comment:2 Changed 8 years ago by dieterdreist

Hi,

my setup:
Repository Root: http://josm.openstreetmap.de/svn
Last Changed Author: framm
Node Kind: directory
Revision: 2368
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2009-11-01 02:48:14 +0100 (Sun, 01 Nov 2009)
Last Changed Rev: 2368
Path: trunk

Memory Usage: 184 MB / 1016 MB (44 MB allocated, but free)
Java version: 1.6.0_0

Plugins: AddrInterpolation
AgPifoJ
Create_grid_of_ways
DirectUpload
PicLayer
buildings_tools
colorscheme
dataimport
editgpx
graphview
measurement
multipoly
openvisible
osmarender
remotecontrol
routing
terracer
utilsplugin
validator
walkingpapers
waydownloader
wmsplugin
Plugin AddrInterpolation Version: 18398
Plugin AgPifoJ Version: 18287
Plugin Create_grid_of_ways Version: 17367
Plugin DirectUpload Version: 17532
Plugin PicLayer Version: 17327
Plugin buildings_tools Version: 24
Plugin colorscheme Version: 16383
Plugin dataimport Version: 18071
Plugin editgpx Version: 18144
Plugin graphview Version: 18130
Plugin measurement Version: 17377
Plugin multipoly Version: 18142
Plugin openvisible Version: 17536
Plugin osmarender Version: 18293
Plugin remotecontrol Version: 18302
Plugin routing Version: 18408
Plugin terracer Version: 17874
Plugin utilsplugin Version: 18387
Plugin validator Version: 18396
Plugin walkingpapers Version: 18408
Plugin waydownloader Version: 18300
Plugin wmsplugin Version: 18408

agpifoj.bounds=474,402,332,226
agpifoj.visible=true
cache.motd.html=1257088395
cache.motd.html.version=2368
cache.wmsplugin.expire=2419200
cache.wmsplugin.maxsize=70
color.conflict=#FF00FF
color.gps marker=#33FFFF
color.gps point=#66FF33
color.node=#FFCCCC
conflict.bounds=474,452,332,126
conflict.visible=true
conflictresolutiondialog.height=763
conflictresolutiondialog.width=1018
conflictresolutiondialog.x=149
conflictresolutiondialog.y=89
coordinates=DECIMAL_DEGREES
download.gps=true
download.tab=2
draw.rawgps.direction=true
draw.rawgps.large=true
draw.rawgps.lines=false
graphview.activeBookmark=pedestrian
graphview.defaultNodeColor=255, 255, 255
graphview.defaultSegmentColor=255, 255, 255
graphview.parameterBookmarks=pedestrian;foot;types={YES,PERMISSIVE,DESIGNATED,UNDEFINED};properties={}|motorcar;motorcar;types={YES,PERMISSIVE,DESIGNATED,UNDEFINED};properties={}|hgv (3.5 t);hgv;types={YES,PERMISSIVE,DESIGNATED,UNDEFINED};properties={WEIGHT=3.5}|bicycle;bicycle;types={YES,PERMISSIVE,DESIGNATED,UNDEFINED};properties={}
graphview.rulesetFolder=/home/mortn
josm.version=2368
laf=javax.swing.plaf.metal.MetalLookAndFeel
language=en
lastAuthorName=dieterdreist
lastDirectory=/home/mortn/OSM/tracks
layerlist.bounds=474,452,332,126
marker.audiofromstart=false
marker.buttonlabels=false
mirror.http://josm.openstreetmap.de/presets=1257088403677;/home/mortn/.josm/mirror_http___josm.openstreetmap.de_presets
mirror.http://josm.openstreetmap.de/styles=1257088403507;/home/mortn/.josm/mirror_http___josm.openstreetmap.de_styles
mirror.http://svn.openstreetmap.org/applications/editors/josm/plugins/validator/ignoretags.cfg=1257088398947;/home/mortn/.josm/plugins/validator/mirror_http___svn.openstreetmap.org_applications_editors_josm_plugins_validator_ignoretags.cfg
mirror.http://svn.openstreetmap.org/applications/editors/josm/plugins/validator/tagchecker.cfg=1257088399139;/home/mortn/.josm/plugins/validator/mirror_http___svn.openstreetmap.org_applications_editors_josm_plugins_validator_tagchecker.cfg
mirror.http://svn.openstreetmap.org/applications/editors/josm/plugins/wmsplugin/sources.cfg=1257088399441;/home/mortn/.josm/plugins/wmsplugin/mirror_http___svn.openstreetmap.org_applications_editors_josm_plugins_wmsplugin_sources.cfg
mirror.http://svn.openstreetmap.org/applications/utils/planet.osm/java/speller/words.cfg=1257088398651;/home/mortn/.josm/plugins/validator/mirror_http___svn.openstreetmap.org_applications_utils_planet.osm_java_speller_words.cfg
org.openstreetmap.josm.gui.conflict.tags.CombinePrimitiveResolverDialog.geometry=x=344,y=399,width=600,height=400
org.openstreetmap.josm.gui.download.DownloadDialog.geometry=x=167,y=400,width=1000,height=600
org.openstreetmap.josm.gui.io.UploadDialog.geometry=x=507,y=400,width=400,height=600
osm-download.bounds=41.8950204363601;12.483308911132207;41.89621143245623;12.484964488742026
osm-primitives.showid=true
osm-server.url=http://www.openstreetmap.org/api
pluginmanager.lastupdate=1257088422170
plugins=AddrInterpolation
AgPifoJ
Create_grid_of_ways
DirectUpload
PicLayer
buildings_tools
colorscheme
dataimport
editgpx
graphview
measurement
multipoly
openvisible
osmarender
remotecontrol
routing
terracer
utilsplugin
validator
walkingpapers
waydownloader
wmsplugin
propertiesdialog.bounds=609,92,332,282
propertiesdialog.docked=false
proxy.anonymous=false
proxy.enable=false
relationlist.visible=true
routing.profile.default.speed.bridleway=40
routing.profile.default.speed.bus_guideway=50
routing.profile.default.speed.byway=50
routing.profile.default.speed.cycleway=40
routing.profile.default.speed.footway=20
routing.profile.default.speed.living_street=30
routing.profile.default.speed.motorway=120
routing.profile.default.speed.motorway_link=120
routing.profile.default.speed.path=40
routing.profile.default.speed.pedestrian=30
routing.profile.default.speed.primary=100
routing.profile.default.speed.primary_link=100
routing.profile.default.speed.residential=50
routing.profile.default.speed.road=100
routing.profile.default.speed.secondary=90
routing.profile.default.speed.service=30
routing.profile.default.speed.steps=10
routing.profile.default.speed.tertiary=90
routing.profile.default.speed.track=50
routing.profile.default.speed.trunk=120
routing.profile.default.speed.trunk_link=120
routing.profile.default.speed.unclassified=50
save.keepbackup=false
selectionlist.bounds=47,173,332,717
shortcut.groups.1=128
shortcut.groups.10=64
shortcut.groups.11=576
shortcut.groups.12=64
shortcut.groups.13=512
shortcut.groups.15=640
shortcut.groups.16=640
shortcut.groups.17=576
shortcut.groups.18=512
shortcut.groups.19=128
shortcut.groups.2=128
shortcut.groups.20=512
shortcut.groups.3=0
shortcut.groups.4=512
shortcut.groups.5=0
shortcut.groups.6=512
shortcut.groups.8=192
shortcut.groups.9=192
shortcut.groups.configured=true
slippymap.autoload_tiles=true
slippymap.autozoom=true
slippymap.draw_debug=false
slippymap.fade_background=0.0
slippymap.max_zoom_lvl=17
slippymap.min_zoom_lvl=13
slippymap.tile_url=http://tah.openstreetmap.org/Tiles/tile
tagimages.lastdirectory=/media/data2/Eigene Bilder/2009_04_11_OSM_Verano+CircoloArt
toolbar=open
save
exportgpx
|
download
upload
|
undo
redo
|
preference
|
|
gps-lines
wayflip
pastetags
tagging_Man-Made/Amenities/Drinking Water
tagging_Man-Made/Amenities/Telephone
upload.comment.history=detailsPOI
details
details colombo + source:maxspeed
details colombo
details Laurentina and tag-change maxspeedtype
details Laurentina
Laurentina EUR
details EUR
details Testaccio
procida ospedale
procida frazioni
procida
marconi
details caffarella
details Roma sud and Center
userlist.bounds=474,427,332,176
userlist.visible=true
validator.bounds=474,427,332,176
validator.tests=Coastlines=true,SimilarNamedWays=true,UntaggedNode=true,CrossingWays=true,NodesWithSameName=true,TagChecker=true,OverlappingWays=true,UnclosedWays=true,WronglyOrderedWays=true,UnconnectedWays=true,SelfIntersectingWay=true,DuplicatedWayNodes=true,DuplicateWay=true,UntaggedWay=true,DuplicateNode=true
validator.testsBeforeUpload=Coastlines=true,SimilarNamedWays=true,UntaggedNode=true,CrossingWays=true,NodesWithSameName=true,TagChecker=true,OverlappingWays=true,UnclosedWays=true,WronglyOrderedWays=true,UnconnectedWays=true,SelfIntersectingWay=true,DuplicatedWayNodes=true,DuplicateWay=true,UntaggedWay=true,DuplicateNode=true
validator.visible=true
wmsplugin.default.html:http://josm.openstreetmap.de/wmsplugin/YahooDirect.html?=true
wmsplugin.default.http://onearth.jpl.nasa.gov/wms.cgi?request_GetMap&layers_global_mosaic&styles_&format_image/jpeg&=true
wmsplugin.default.http://openaerialmap.org/wms/?VERSION_1.0&request_GetMap&layers_world&styles_&format_image/jpeg&=true
wmsplugin.url.0.name=LandSat
wmsplugin.url.0.url=http://onearth.jpl.nasa.gov/wms.cgi?request=GetMap&layers=global_mosaic&styles=&format=image/jpeg&
wmsplugin.url.1.name=OpenAerial-Karte
wmsplugin.url.1.url=http://openaerialmap.org/wms/?VERSION=1.0&request=GetMap&layers=world&styles=&format=image/jpeg&
wmsplugin.url.2.name=Yahoo Sat
wmsplugin.url.2.url=html:http://josm.openstreetmap.de/wmsplugin/YahooDirect.html?
wmsplugin.url.overlap=false
wmsplugin.url.overlapEast=14
wmsplugin.url.overlapNorth=4

for the node issue:
yes, the via dell'Elettronica is of course a road, but the possibility to rearrange nodes for a way manually seems still strange to me. I bet that you don't need this in 99,9% of the cases, still you have to deal with it on every conflict?

Maybe the conflict arose, because I deleted the created by potlatch-tag? I noted that JOSM does this also automatically. I was editing for some hours without any further problem, so maybe that was just bad luck ( ;-) )?

I also noticed that the hidden menu-items (see screenshot) became visible by changing the _width_ of the dialogue (still strange, because it is a height issue).

Don't know how I got 4 nodes, I guess they are not all from the same road? I tried to take all of my versions (this was much easier before) but somehow mixed up the order. I could resolve by changing the way order (at least I think I resolved).

comment:3 Changed 8 years ago by Gubaer

I bet that you don't need this in 99,9% of the cases, still you have to deal with it on every conflict?

No, you don't have to, only if the conflict is caused by differences in the list of nodes. And for some reason (I don't understand yet, why) you got a conflict in the list of nodes. But if there is a conflict in the list of nodes a way is made up there is not other option than to resolve it manually and this means rearranging the nodes.

Can you still reproduce the problem or did it disappear?

comment:4 in reply to:  3 Changed 8 years ago by dieterdreist

Resolution: worksforme
Status: newclosed

Replying to Gubaer:

Can you still reproduce the problem or did it disappear?

disappeared...

comment:5 Changed 8 years ago by dieterdreist

Resolution: worksforme
Status: closedreopened

There is some problems with conflict management:

  1. if you cancel upload of even small datasets you'll get hundreds of conflicts to solve that consist mainly of created-by tags beeing removed. There is no way to do this for all errors (like: treat all tag conflicts of this kind the same, that is: use their version (undefined/undefined)), so it take lots of time to solve these unnecessary conflicts.
  1. The solve nodes conflicts-manager is not working as it should, because:

2.1 there is no button to take the complete list of nodes in their order ("copy all nodes"), you can do this by selecting all nodes, but it is not obvious (usability)
2.2 there is several buttons: "copy this node and put it at the beginning", "copy this node before the first" (is exactly the same), "copy this node after the first", "copy this node to the end". It would IMHO be better to have the button: to the beginning, to the end, after the last, before the last, where the last is not the end of the list, but the last entry.
2.3 at the end of half an hour conflict management work I still couldn't upload because resolved node-conflicts (Freeze->resolve) remain in the conflict list: even though all conflicts were marked as resolved I got a conflict error. I got the solution: had to select again each of them, click on unfreeze, then again on freeze, then again resolve, and here we go.
2.4 There is no key map for the meaning of the colours. Additionally with a monochrome display or partly disabled (poor red-green hue discrimination) you can not deal with conflicts.
2.5 some nodes and ways were duplicated (had different IDs, probably this is more a problem with incomplete upload then with conflict management)

  1. basically there should be more possibilities to solve similar conflicts (same kind of tag-conflict) with one click, instead of solving them one by one.

comment:6 Changed 8 years ago by avarab@…

Keywords: conflict upload added; conflic management removed

comment:7 Changed 8 years ago by skyper

The 3. point would be a big enhancement.

comment:8 Changed 7 years ago by dieterdreist

Type: defectenhancement

Modify Ticket

Change Properties
Set your email in Preferences
Action
as reopened The owner will remain team.
as The resolution will be set.
to The owner will be changed from team to the specified user.
The owner will change to dieterdreist
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.