Modify

Opened 9 years ago

Closed 9 years ago

#3811 closed defect (worksforme)

error when trying to grab cadastre.

Reported by: c-quad Owned by: c-quad
Priority: normal Milestone:
Component: Plugin cadastre-fr Version:
Keywords: Cc:

Description (last modified by stoecker)

Manifest-Version: 1.0
Ant-Version: Apache Ant 1.7.1
Created-By: 14.0-b16 (Sun Microsystems Inc.)
Main-class: JOSM
Main-Version: 2255 SVN
Main-Date: 2009-10-07T19:25:15.114514Z
Memory Usage: 105 MB / 872 MB (27 MB allocated, but free)
Java version: 1.6.0_0

Plugins: cadastre-frvalidatorwmsplugin
Plugin validator Version: 17722
Plugin wmsplugin Version: 17817
Plugin cadastre-fr Version: 18289

java.lang.NoClassDefFoundError: org/openstreetmap/josm/data/projection/LambertCC9Zones

at cadastre_fr.MenuActionNewLocation.addNewLayer(MenuActionNewLocation.java:82)
at cadastre_fr.WMSDownloadAction.getLayer(WMSDownloadAction.java:41)
at cadastre_fr.MenuActionGrab.actionPerformed(MenuActionGrab.java:35)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2012)
at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2335)
at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:404)
at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
at javax.swing.AbstractButton.doClick(AbstractButton.java:374)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1688)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1732)
at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
at java.awt.Component.processMouseEvent(Component.java:6108)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3276)
at java.awt.Component.processEvent(Component.java:5873)
at java.awt.Container.processEvent(Container.java:2105)
at java.awt.Component.dispatchEventImpl(Component.java:4469)
at java.awt.Container.dispatchEventImpl(Container.java:2163)
at java.awt.Component.dispatchEvent(Component.java:4295)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4461)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4125)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4055)
at java.awt.Container.dispatchEventImpl(Container.java:2149)
at java.awt.Window.dispatchEventImpl(Window.java:2478)
at java.awt.Component.dispatchEvent(Component.java:4295)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:604)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

Caused by: java.lang.ClassNotFoundException: org.openstreetmap.josm.data.projection.LambertCC9Zones

at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:336)
... 31 more

Attachments (0)

Change History (2)

comment:1 Changed 9 years ago by stoecker

Component: CorePlugin cadastre-fr
Description: modified (diff)
Owner: changed from team to c-quad
Status: newneedinfo

Very likely your josm version and the cadastre-plugin do not match. Please update both and retry. Tell results.

comment:2 Changed 9 years ago by stoecker

Resolution: worksforme
Status: needinfoclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain c-quad.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.