Modify

Opened 12 years ago

Closed 12 years ago

#3810 closed defect (fixed)

Pressing Enter in download dialog doesn't initiate download anymore

Reported by: avarab@… Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

On r2347. I'm pretty sure this is a regression and it worked before.

Attachments (0)

Change History (5)

comment:1 Changed 12 years ago by avarab@…

Resolution: worksforme
Status: newclosed

Hrm, actually the focus got out of wack somehow and I can't reproduce it now...

comment:2 Changed 12 years ago by avarab@…

Resolution: worksforme
Status: closedreopened

Actually:

  1. Open download dialog
  2. Select OSM/GPS layer
  3. Selection on download button is released

Then Enter won't download anymore.

comment:3 Changed 12 years ago by Gubaer

Resolution: wontfix
Status: reopenedclosed

AFAIK, it never did, unless the "Download" button hat focus. IMHO, this is how it should be. For instance, the download button behaves the same way: upload with enter only if the upload button has focus.

If you really necessary I could add "tabbing" with ENTER, as I did in the download dialog. You would click in the "Download GPX", then press ENTER once or twice until the download button has focus, then press ENTER to downlolad.

comment:4 in reply to:  3 Changed 12 years ago by avarab@…

Resolution: wontfix
Status: closedreopened

Replying to Gubaer:

AFAIK, it never did, unless the "Download" button hat focus. IMHO, this is how it should be. For instance, the download button behaves the same way: upload with enter only if the upload button has focus.

It did work in the past actually. If I build r2300 and:

  1. Open the download dialog
  2. Select/Unselect OSM/GPX so that there's a small box around it
  3. Press Enter

Nothing happens in trunk but r2300 initiates the download. It's as if there's an Enter listener on the entire area of the dialog in r2300 but not in trunk.

Having it work like this on the download dialog isn't going to destroy any data, unlike potentially on the upload dialog.

For what it's worth this made a minor part of my workflow with JOSH slightly more tedious, hence filing the bug:)

Reopening since it did work in the past, but you can do what you want with it.

I could add "tabbing" with ENTER, as I did in the download dialog. You would click in the "Download GPX", then press ENTER once or twice until the download button has focus, then press ENTER to downlolad.

How did this work before the layout of the dialog was changed? Then one only needed to press Enter once.

comment:5 Changed 12 years ago by Gubaer

Resolution: fixed
Status: reopenedclosed

(In [2529]) fixed #3810: Pressing Enter in download dialog doesn't initiate download anymore
If focus is on either of the three checkboxes in the download dialog, pressing ENTER now triggers the download action.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.