Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#3795 closed defect (fixed)

download has wrong coordinates

Reported by: anonymous Owned by: team
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

The download cleanup was a bit too overeager. Since then the download dialog does not download the area in the editor but instead the area it downloaded the last time.

How to reproduce:
1.) Download some area.
2.) Move to another area in the editor.
3.) Download now wants to download area 1.) and not area 2.)

With this bug and the fact that I cannot go back in version history because of plugin dependencies JOSM is currently completely unusable! Please fix ASAP.

Attachments (0)

Change History (8)

comment:1 Changed 9 years ago by anonymous

Resolution: fixed
Status: newclosed

This is fixed in [2330], see #3794

comment:2 Changed 9 years ago by andre68@…

Resolution: fixed
Status: closedreopened

Just tried r2333 without success. Same behaviour as described. You do not necessarily have to remove the data layer (as described in #3794) to get this behaviour.

comment:3 Changed 9 years ago by Gubaer

Resolution: worksforme
Status: reopenedclosed

Can't reproduce.

Please be more specific. What exactly doesn't work?

comment:4 Changed 9 years ago by anonymous

Resolution: worksforme
Status: closedreopened

Thought, I described it precise enough and I'm surprised that you cannot reproduce it.

To be exact here is my complete procedure:

cd josm
svn up
ant clean
ant dist
java -Xmx512M -jar dist/josm-custom.jar

download a small area
move to a not downloaded area (where you have the diagonal lines)
download (the coordinates are from the first download and didn't change) > Download

the displayed area remains empty (with diagonal lines)

Interestingly the following procedure works:

java -Xmx512M -jar dist/josm-custom.jar

download a small area
save osm data to /tmp/xxx.osm
exit

java -Xmx512M -jar dist/josm-custom.jar /tmp/xxx.osm

move to empty area
download (the coordinates have now changed) > Download

the displayed area contains the correct data

I haven't yet found a way to get this working without quitting josm.

If you still cannot reproduce, I will send you my josm-custom.jar for more checks.

comment:5 Changed 9 years ago by anonymous

Argh, should have used preview...

Thought, I described it precise enough and I'm surprised that you cannot reproduce it.

To be exact here is my complete procedure:

> cd josm
> svn up
> ant clean
> ant dist
> java -Xmx512M -jar dist/josm-custom.jar
>> download a small area
>> move to a not downloaded area (where you have the diagonal lines)
>> download (the coordinates are from the first download and didn't change) > Download
>>> the displayed area remains empty (with diagonal lines)

Interestingly the following procedure works:

> java -Xmx512M -jar dist/josm-custom.jar
>> download a small area
>> save osm data to /tmp/xxx.osm
>> exit josm
> java -Xmx512M -jar dist/josm-custom.jar /tmp/xxx.osm
>> move to empty area download (the coordinates have now changed) > Download
>>> the displayed area contains the correct data

I haven't yet found a way to get this working without quitting josm.

If you still cannot reproduce, I will send you my josm-custom.jar for more checks.

comment:6 Changed 9 years ago by Gubaer

I think I understand now what is not working. I always tried to select a different download area in the slipply map browser in the download dialog. I didn't try to shift the main map view and lauch a download from that.

comment:7 Changed 9 years ago by Gubaer

Resolution: fixed
Status: reopenedclosed

(In [2335]) fixed #3795: download has wrong coordinates

comment:8 Changed 9 years ago by anonymous

Corfirmed fixed. Thanks!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.