Modify

Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#3792 closed defect (fixed)

NPE when deleting the data layer while the deletion tool is active

Reported by: skela Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

Manifest-Version: 1.0
Ant-Version: Apache Ant 1.7.0
Created-By: 11.2-b01 (Sun Microsystems Inc.)
Main-class: JOSM
Main-Version: 2300 SVN
Main-Date: 2009-10-18T18:19:40.122791Z
Memory Usage: 79 MB / 496 MB (2 MB allocated, but free)
Java version: 1.6.0_12

Plugins: AgPifoJ
dataimport
openstreetbugs
openvisible
osmarender
validator
Plugin AgPifoJ Version: 17707
Plugin dataimport Version: 18071
Plugin openstreetbugs Version: 18147
Plugin openvisible Version: 17536
Plugin osmarender Version: 18200
Plugin validator Version: 18197

java.lang.NullPointerException

at org.openstreetmap.josm.actions.mapmode.DeleteAction.updateCursor(DeleteAction.java:178)
at org.openstreetmap.josm.actions.mapmode.DeleteAction.eventDispatched(DeleteAction.java:376)
at java.awt.Toolkit$SelectiveAWTEventListener.eventDispatched(Toolkit.java:2353)
at java.awt.Toolkit$ToolkitEventMulticaster.eventDispatched(Toolkit.java:2245)
at java.awt.Toolkit.notifyAWTEventListeners(Toolkit.java:2203)
at java.awt.Component.dispatchEventImpl(Component.java:4481)
at java.awt.Container.dispatchEventImpl(Container.java:2099)
at java.awt.Component.dispatchEvent(Component.java:4413)
at java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1848)
at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:704)
at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:969)
at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:841)
at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:668)
at java.awt.Component.dispatchEventImpl(Component.java:4455)
at java.awt.Container.dispatchEventImpl(Container.java:2099)
at java.awt.Window.dispatchEventImpl(Window.java:2475)
at java.awt.Component.dispatchEvent(Component.java:4413)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (0)

Change History (2)

comment:1 by Gubaer, 15 years ago

Resolution: fixed
Status: newclosed

(In [2343]) fixed #3792: NPE when deleting the data layer while the deletion tool is active

comment:2 by anonymous, 15 years ago

Ticket #3752 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.