Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#3614 closed defect (fixed)

JOSM not displaying all loaded ways.

Reported by: delta_foxtrot2 Owned by: team
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: Cc: delta_foxtrot2

Description

If I download this area:

http://www.openstreetmap.org/?lat=-21.6709&lon=147.2176&zoom=14

and then download this area:

http://www.openstreetmap.org/?lat=-21.46919&lon=146.90355&zoom=16

The boundary isn't displayed and this error appears at the console:

Sep 29, 2009 2:08:17 PM org.openstreetmap.josm.data.osm.visitor.MergeVisitor mergeById
WARNING: My primitive with id 32259742 and version 0 is visible although their primitive with lower version 1 is not visible. Cant deal with this inconsistency. Keeping my primitive.
Sep 29, 2009 2:08:17 PM org.openstreetmap.josm.data.osm.visitor.MergeVisitor mergeById
WARNING: My primitive with id 32288978 and version 0 is visible although their primitive with lower version 1 is not visible. Cant deal with this inconsistency. Keeping my primitive.

You can get the exact same issue if you delete any loaded layers and load the areas in reverse, the second loaded area won't show the admin boundary. The end result is I think the area has been deleted so I add the area in again.

Attachments (0)

Change History (12)

comment:1 Changed 9 years ago by delta_foxtrot2

Ticket #3610 has been marked as a duplicate of this ticket.

comment:2 Changed 9 years ago by delta_foxtrot2

Priority: criticalblocker

comment:3 Changed 9 years ago by delta_foxtrot2

Summary: missing boundariesJOSM not displaying all loaded ways.

comment:4 Changed 9 years ago by Gubaer

Owner: changed from team to delta_foxtrot2
Status: newneedinfo

Replying exactly what you describe above but can't reproduce: no console output, no problem.

What version are you working with? OS? Java version? Plugins?

comment:5 Changed 9 years ago by delta_foxtrot2

Owner: changed from delta_foxtrot2 to team
Status: needinfonew

$ java -version
java version "1.6.0_14"
Java(TM) SE Runtime Environment (build 1.6.0_14-b08)
Java HotSpot(TM) 64-Bit Server VM (build 14.0-b16, mixed mode)

Last Changed Author: stoecker
Last Changed Rev: 2209
Last Changed Date: 2009-09-28 17:35:06 +0200 (Mon, 28 Sep 2009)

Same thing happened in 2206 as well. This problem didn't occur until I upgraded to 2206, not sure what version I was using before that, but I upgraded to 2206 because the wmsplugin wasn't working.

comment:6 Changed 9 years ago by delta_foxtrot2

Complete output from following my above instructions:

GET http://api.openstreetmap.org/api/capabilities... OK
Communications with http://api.openstreetmap.org/api established using protocol version 0.6.
GET http://api.openstreetmap.org/api/0.6/map?bbox=147.206613671875,-21.6763931640625,147.228586328125,-21.6654068359375
returning array list with size: 756
GET http://api.openstreetmap.org/api/0.6/map?bbox=146.90080341796875,-21.470563291015626,146.90629658203125,-21.467816708984376
returning array list with size: 833
returning array list with size: 833
Sep 29, 2009 4:30:42 PM org.openstreetmap.josm.data.osm.visitor.MergeVisitor mergeById
WARNING: My primitive with id 32259742 and version 0 is visible although their primitive with lower version 1 is not visible. Cant deal with this inconsistency. Keeping my primitive. 
Sep 29, 2009 4:30:42 PM org.openstreetmap.josm.data.osm.visitor.MergeVisitor mergeById
WARNING: My primitive with id 32288978 and version 0 is visible although their primitive with lower version 1 is not visible. Cant deal with this inconsistency. Keeping my primitive. 

comment:7 Changed 9 years ago by t-i

Same problem here! ANY second download produces several MergeVisitor-Failures! It does not matter if the second download is overlapping the first one or not.

Java 1.6.0_15, Windows XP and Windows Vista, JOSM 2209

comment:8 Changed 9 years ago by Claudius

Reproducable here as well using Java 1.6.0_16, Vista64, JOSM 2209.

Steps to reproduce:
1) Download an area
2) Download an area with new ways connecting to nodes already downloaded in step 1

Result:
Nodes of the new ways are shown but not the way itself.

comment:9 Changed 9 years ago by Gubaer

(In [2213]) see #3614: JOSM not displaying all loaded ways

comment:10 Changed 9 years ago by Gubaer

Resolution: fixed
Status: newclosed

There were some optimizations applied in r2206. As a sideeffect primitives became invisible per default.

Should be fixed in r2213.

comment:11 Changed 9 years ago by Gubaer

(In [2214]) see #3614: JOSM not displaying all loaded ways
hmm, *this* is the way to init the flags, right? (fixing my first attempt in r2213)

comment:12 Changed 9 years ago by Gubaer

(In [2216]) see #3614: JOSM not displaying all loaded ways
argh, this should do it ;-)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.