Modify

Opened 12 years ago

Closed 12 years ago

#3569 closed defect (fixed)

deffect on cadastre-fr.plugin (last version)

Reported by: jf.giron@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

Here is a message after an update of cadastre-dr plugin. The error arrise when i try to use the cadastre plugin, just after clicking "cadastre grab" in Cadastre menu.

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1788
Node Kind: directory
Last Changed Author: stoecker
Last Changed Rev: 1788
Last Changed Date: 2009-07-14 18:20:56 +0200 (Tue, 14 Jul 2009)

Memory Usage: 23 MB / 63 MB (3 MB allocated, but free)
Java version: 1.6.0_12

Plugins: buildings_toolscadastre-frcolorschemedataimportopenstreetbugsosmarendertageditor
Plugin buildings_tools Version: 19
Plugin colorscheme Version: 16383
Plugin dataimport Version: 16382
Plugin openstreetbugs Version: 16564
Plugin osmarender Version: 16239
Plugin tageditor Version: 16575
Plugin cadastre-fr Version: 16023

java.lang.RuntimeException: java.lang.NoSuchFieldError: progressMonitor

at org.openstreetmap.josm.gui.PleaseWaitRunnable$3.run(PleaseWaitRunnable.java:120)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Caused by: java.lang.NoSuchFieldError: progressMonitor

at cadastre_fr.DownloadWMSVectorImage.realRun(DownloadWMSVectorImage.java:29)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:95)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:144)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:619)

Attachments (0)

Change History (1)

comment:1 Changed 12 years ago by pieren

Resolution: fixed
Status: newclosed

This may happen when your JOSM version does not correspond to the plugin version. Please download josm-tested.jar and use the preference dialog to upgrade the plugins. Then it should work.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.