Modify

Opened 12 years ago

Closed 12 years ago

#3448 closed defect (fixed)

exception error in wms plugin

Reported by: mk67 Owned by: dmuecke
Priority: major Milestone:
Component: Core imagery Version: latest
Keywords: Cc:

Description

plugin doesn't understand autors and stop.
Here the log at plugin launch:

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 2091
Node Kind: directory
Last Changed Author: ulfl
Last Changed Rev: 2091
Last Changed Date: 2009-09-09 22:54:13 +0200 (Wed, 09 Sep 2009)

Memory Usage: 551 MB / 1066 MB (419 MB allocated, but free)
Java version: 1.6.0_14

Plugins: Create_grid_of_waysDirectUploadIntersect_wayPicLayerbuildings_toolscadastre-frcolorschemedataimportlakewalkermultipolyterracerusertoolsutilspluginvalidatorwaydownloaderwmsplugin
Plugin Create_grid_of_ways Version: 16620
Plugin DirectUpload Version: 17532
Plugin Intersect_way Version: 12781
Plugin PicLayer Version: 17327
Plugin buildings_tools Version: 21
Plugin colorscheme Version: 16383
Plugin dataimport Version: 16382
Plugin lakewalker Version: 17375
Plugin multipoly Version: 16609
Plugin terracer Version: 17388
Plugin usertools Version: 17359
Plugin utilsplugin Version: 17550
Plugin validator Version: 17540
Plugin waydownloader Version: 16963
Plugin wmsplugin Version: 17556
Plugin cadastre-fr Version: 17528

java.lang.NullPointerException

at wmsplugin.WMSLayer.<init>(WMSLayer.java:91)
at wmsplugin.WMSLayer.<init>(WMSLayer.java:73)
at wmsplugin.WMSPlugin$1.actionPerformed(WMSPlugin.java:186)
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
at javax.swing.AbstractButton.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)
at javax.swing.JComponent.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (3)

comment:1 Changed 12 years ago by dmuecke

Owner: changed from team to dmuecke
Status: newassigned

comment:2 Changed 12 years ago by stoecker

Ticket #3903 has been marked as a duplicate of this ticket.

comment:3 Changed 12 years ago by jttt

Resolution: fixed
Status: assignedclosed

Already fixed. I'm not sure in which version but o19626 works fine.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain dmuecke.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.