Modify

Opened 11 years ago

Closed 11 years ago

#3400 closed enhancement (fixed)

relation editor: improvement to highlight an element

Reported by: malenki Owned by: Gubaer
Priority: major Milestone:
Component: Core Version: latest
Keywords: relation editor highlighting Cc: igor.podolskiy@…, bilbo

Description

Some time ago this feature did exist. P.e. it's very useful for merging two relations into one or shifting some of the members so please re-add it.

regards
malenki

Attachments (1)

relation_editor.png (212.8 KB) - added by vsandre 11 years ago.
example

Download all attachments as: .zip

Change History (13)

comment:1 Changed 11 years ago by malenki

Summary: selected members or relations aren't hilighted at datalayerselected members of relations aren't hilighted at datalayer

comment:2 Changed 11 years ago by podolsir

Cc: igor.podolskiy@… added

comment:3 Changed 11 years ago by bilbo

Cc: bilbo added

comment:4 Changed 11 years ago by malenki

Version: latest

At the moment one has to select some of the entries which one thinks they are the wanted ones, click on "select selected items" (that's the translation of the german description) to get them hilighted/selected at the datalayer.
I still prefer the old behaviour: selecting at the relation-editor=selecting at the datalayer.

Or is there a certain reason tat this behaviour is not wanted anymore?

comment:5 Changed 11 years ago by vsandre

Priority: normalmajor

Here are some improvements for the relation editor:

element table: (left table)

  • double click on an element should select it in the data layer
  • the background of all selected primitives (see right table) should be highlighted, e.g. green

current selection: (right table)

  • double click on an element should select it in the element table (left table)

buttons:

  • all buttons with a similar aim should be grouped together.
    • so all buttons with several types of adding elements in a row at the top
    • selectAction and selectMembersForSelectionAction should grouped or deleted
    • removeSelectedAction grouped to above or separate at the bottom

Changed 11 years ago by vsandre

Attachment: relation_editor.png added

example

comment:6 Changed 11 years ago by anonymous

Summary: selected members of relations aren't hilighted at datalayerrelation editor: improvement to highlight an element
Type: defectenhancement

because of the last comment and the fact that it is not possible to reimplement the old behaviour, I changed the title and type from defect to enhancement

comment:7 Changed 11 years ago by malenki

To alter vsandres suggestion I'd say it would be the easiest way would be just highlighting (_not_ selecting) the in the relation-editor selected members at the datalayer.
With highlighting I mean the way of showing the selection which is used when a relation at the list in josm is double-clicked.

comment:8 Changed 11 years ago by plaicy

Ticket #3299 has been marked as a duplicate of this ticket.

comment:9 in reply to:  7 Changed 11 years ago by vsandre

Replying to malenki:

To alter vsandres suggestion I'd say it would be the easiest way would be just highlighting (_not_ selecting) the in the relation-editor selected members at the datalayer.
With highlighting I mean the way of showing the selection which is used when a relation at the list in josm is double-clicked.

At the moment only selected primitives are highlighted in the map with a red colour. If you want to highlight something without selecting it, there must be a new class and colour. So in my opinion this should be the second step, after doing the things mentioned above.

comment:10 Changed 11 years ago by anonymous

Keywords: relation editor highlighting added

comment:11 Changed 11 years ago by Gubaer

Owner: changed from team to Gubaer

comment:12 Changed 11 years ago by Gubaer

Resolution: fixed
Status: newclosed

(In [2563]) fixed #3400: relation editor: improvement to highlight an element
fixed #3873: Feature request: download selected elements in relation editor
New: Dbl-Click in member table to set the map selection to this member
New: Ctrl-Dbl-Clik in member table to add the member to the the map selection
New: Download selected incomplete members only

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Gubaer.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.