Modify

Opened 12 years ago

Closed 12 years ago

#3298 closed enhancement (fixed)

WMS -Warn if URL is not correct

Reported by: juelie Owned by: dmuecke
Priority: normal Milestone:
Component: Core imagery Version: latest
Keywords: Cc:

Description

nach Update geht unter Windows XP kein WMS mehr

Landsat
<!DOCTYPE ServiceExceptionReport SYSTEM "http://schemas.opengis.net/wms/1.1.1/ex
ception_1_1_1.dtd">
<ServiceExceptionReport version="1.1.1">
<ServiceException code="LayerNotDefined">
msWMSLoadGetMapParams(): WMS server error. Invalid layer(s) given in the LAYERS
parameter.
</ServiceException>
</ServiceExceptionReport>
Image couldn't be fetched: http://onearth.jpl.nasa.gov/wms.cgi?request=GetMap&la
yers=global_mosaic&styles=&srs=EPSG:4326&format=image/jpegbbox=12.3432228,51.198
2974,12.4301469,51.2852215&width=499&height=499

at wmsplugin.WMSGrabber.fetch(WMSGrabber.java:70)
at wmsplugin.Grabber.attempt(Grabber.java:68)
at wmsplugin.WMSGrabber.run(WMSGrabber.java:48)
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source

)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

eigener WMS-Server
<!DOCTYPE ServiceExceptionReport SYSTEM "http://schemas.opengis.net/wms/1.1.1/ex
ception_1_1_1.dtd">
<ServiceExceptionReport version="1.1.1">
<ServiceException code="LayerNotDefined">
msWMSLoadGetMapParams(): WMS server error. Invalid layer(s) given in the LAYERS
parameter.
</ServiceException>
</ServiceExceptionReport>

Image couldn't be fetched: http://192.168.1.39/cgi-bin/mapserv.exe?map=C:/Daten/
WMS/orto2.map&REQUEST=GETMap&service=WMS&version=1.1.1&srs=EPSG:4326&FORMAT=imag
e/png&layers=Orthofotobbox=12.5170710,51.1982974,12.6039951,51.2852215&width=499
&height=500

at wmsplugin.WMSGrabber.fetch(WMSGrabber.java:70)
at wmsplugin.Grabber.attempt(Grabber.java:68)
at wmsplugin.WMSGrabber.run(WMSGrabber.java:48)
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source

)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

Mit der vorigen Version JOSM 1669 funktionierte alles bestens.

MfG
juelie

Attachments (0)

Change History (6)

comment:1 Changed 12 years ago by dmuecke

Owner: changed from team to dmuecke
Status: newassigned

comment:2 Changed 12 years ago by anonymous

Summary: WMS Plugin geht nicht - XP,-JOSM 1981, WMS 16872WMS -Warn if URL is not correct
Type: defectenhancement

You need to add an "&" at the end of the URL's. WMSPlugin is more strict about this now. This was already the case with 1788. Maybe we should issue a warning when the URL is wrong.

comment:3 Changed 12 years ago by dmuecke

Not all URLs mentioned in WMS plugin require & character so showing a warning would lead to other bug reports in trac. I would recommend to close this bug report without further action.

comment:4 Changed 12 years ago by dmuecke

Can we close this?

comment:5 Changed 12 years ago by stoecker

Well, the warning should be temporary to fix old installations. When No '/', '?' or '&' is at the end, a warning may be issued.

comment:6 Changed 12 years ago by Gubaer

Resolution: fixed
Status: assignedclosed

fixed in [o17407]

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain dmuecke.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.