Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#3216 closed defect (duplicate)

JavaWS does not work

Reported by: anonymous Owned by: anonymous
Priority: major Milestone:
Component: Core Version: tested
Keywords: webstart Cc: richardbrinkman@…

Description

If I start JOSM by "javaws http://josm.openstreetmap.de/download/josm.jnlp", I get the following exception:
net.sourceforge.jnlp.LaunchException: Fatal: Launch Error: Could not launch JNLP file.

at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:395)
at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:623)

Caused by: java.lang.NoSuchMethodException: JOSM.main([Ljava.lang.String;)

at java.lang.Class.getDeclaredMethod(Class.java:1954)
at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:374)
... 1 more

Caused by:
java.lang.NoSuchMethodException: JOSM.main([Ljava.lang.String;)

at java.lang.Class.getDeclaredMethod(Class.java:1954)
at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:374)
at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:623)

This error can be resolved by changing one line in the josm.jnlp file:
Change:
<application-desc main-class="JOSM"/>
into:
<application-desc main-class="org.openstreetmap.josm.gui.MainApplication"/>
I don't have an svn account for josm, so can somebody change this for me?

Used openJDK 1.6.0_0 (64 bits) on linux.

Attachments (0)

Change History (6)

comment:1 Changed 10 years ago by anonymous

AFAIK, josm.jnlp wasn't in the SVN yet. I've added it in r1931 but I didn't apply the suggested changes yet. Somebody with access to http://josm.openstreetmap.de/download will have to do it and test it.

comment:2 Changed 10 years ago by stoecker

Owner: changed from team to anonymous
Status: newneedinfo

I don't see the sense in this change. JOSM has a wrapper class JOSM. And the webstart works also. I assume the bug reporter did somehow compile an own version which missed the JOSM wrapper.

The wrapper is used to have clean program name on some systems.

comment:3 Changed 10 years ago by anonymous

What information, other than the error trace, the way I invoked javaws and my Java version, do you want to know?

Maybe that it runs with other Java implementations like the Windows version or the SUN release, but not with the linux version of OpenJDK 1.6.0.

comment:4 Changed 10 years ago by plaicy

Keywords: webstart added

comment:5 Changed 10 years ago by plaicy

Resolution: duplicate
Status: needinfoclosed

comment:6 Changed 10 years ago by plaicy

Closed as duplicate of #2299.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain anonymous.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.