Modify

Opened 9 years ago

Closed 9 years ago

#2299 closed defect (wontfix)

Java WebStart doesn't work under OpenJDK 6 (java.lang.NoSuchMethodException JOSM.main)

Reported by: avarab@… Owned by: team
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: webstart Cc:

Description

Under Ubuntu 8.10:

avar@aoeu:~$ /usr/lib/jvm/java-6-openjdk/jre/bin/javaws http://josm.openstreetmap.de/download/josm.jnlp
netx: Launch Error: Could not launch JNLP file. (java.lang.NoSuchMethodException JOSM.main([Ljava.lang.String;))
net.sourceforge.jnlp.LaunchException: Fatal: Launch Error: Could not launch JNLP file.
	at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:372)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:600)
Caused by: java.lang.NoSuchMethodException: JOSM.main([Ljava.lang.String;)
	at java.lang.Class.getDeclaredMethod(Class.java:1954)
	at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:358)
	... 1 more
Caused by: 
java.lang.NoSuchMethodException: JOSM.main([Ljava.lang.String;)
	at java.lang.Class.getDeclaredMethod(Class.java:1954)
	at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:358)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:600)

Using Sun Java 6 works however.

Attachments (0)

Change History (5)

comment:1 Changed 9 years ago by anonymous

Interesting! I have the same "problem". But if I click "webstart" on the mainpage of josm here it works.

comment:2 Changed 9 years ago by plaicy

Keywords: webstart added

comment:3 Changed 9 years ago by plaicy

Ticket #3216 has been marked as a duplicate of this ticket.

comment:4 Changed 9 years ago by xeen

http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=216

This is/was a known issue and apparently a bugfix has been checked in and pushed for Fedora. Hopefully other distributions catch up soon and WebStart will work for many.

comment:5 Changed 9 years ago by stoecker

Resolution: wontfix
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.