Modify

Opened 10 years ago

Closed 5 years ago

Last modified 5 years ago

#3123 closed enhancement (fixed)

JOSM should have a .desktop file for KDE/Gnome/etc

Reported by: ian@… Owned by: team
Priority: minor Milestone: 14.08
Component: Core Version:
Keywords: Cc:

Description

It is standard for GUI apps to have a .desktop file so the GUI environments can list it in the menu. The attachment is a starting point; the Name entry needs to be L10N'd into more languages, but it works and is a starting point. The osm_logo.png that I use on my system was just downloaded from the OSM home page; this needs to be vetted for copyright, but presumably is "OK" as JOSM is now part of OSM??

Attachments (2)

josm.desktop (206 bytes) - added by anonymous 10 years ago.
josm.2.desktop (229 bytes) - added by anonymous 10 years ago.
desktop file from debian

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by anonymous

Attachment: josm.desktop added

Changed 10 years ago by anonymous

Attachment: josm.2.desktop added

desktop file from debian

comment:1 Changed 10 years ago by anonymous

There is also a desktop file in the debian dir of the debian package. I attached the file.

comment:2 Changed 10 years ago by stoecker

Actually I think this is a plain packaging issue. Debian dir is outdated a lot I assume. Packages in OpenSUSE BuildService (including packages for SUSE, Fedora and Mandriva) have their own .desktop file.

comment:3 Changed 10 years ago by ian@…

Either way, the .desktop file should be in the SVN repo; I just checked out the /trunk/ and it is not there.
"Common" packaging files like the desktop file are needed not just on Linux but also OpenBSD (the one I did this for), Solaris, HP/UX and others. Obviously distribution-specific files like the OpenBSD makefile or the Debian RPM stuff doesn't need to be in SVN as it is distro-specific, and are at least 50-50% likely to be maintained by the distribution rather than by JOSM, but the desktop file is (barring path issues, which can be fixed with sed) universally required on all *NIX platforms. It and the PNG that it needs should be in a subdirectory called, say, packaging, or similar.

Thanks.

comment:4 Changed 5 years ago by Don-vip

Milestone: 14.08

comment:5 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7403/josm:

fix #3123, fix #10069 - Linux: add .desktop and AppData files

comment:6 Changed 5 years ago by Don-vip

In 7405/josm:

see #3123, see #10069 - fix .desktop and AppData files

comment:7 Changed 5 years ago by Don-vip

Ticket #6724 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.