Modify

Opened 10 years ago

Closed 10 years ago

#3109 closed defect (fixed)

Layer selected when clicking in empty space in layer dialog

Reported by: dieterdreist Owned by: Gubaer
Priority: minor Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

I find that recently the order of the windows and alerts is generally messed up. (using WinXP). E.g. alerts like "2 plugins updated, please restart JOSM" result under the progress-bar of the update, and even on highlight remain below. You have to move them in order to click OK (fortunately slightly more height than the progress window, otherwise would even be a blocker). Please see also these tickets:
http://josm.openstreetmap.de/ticket/3099

Attachments (0)

Change History (9)

comment:1 Changed 10 years ago by dieterdreist

Priority: majorcritical

The properties-window is no longer on top of the map. After every selection/click on the map you must select it again to see it.

comment:2 Changed 10 years ago by Gubaer

Priority: criticalminor

The problem with JOSM is that I can open a lot of windows on top of the map window: detached dialogs, relation editors, history browsers, conflict resolvers, and, on top of this, progress indicators and message dialogs.

The problem was that quite often mesage dialogs got hidden and JOSM became blocked unless you knew that "ESC" would usually close the hidden dialog.

Recently, new code for handling message dialogs has been added to JOSM. Unfortunatelly, we still have to change the whole existing code to this new approach. For the plugin subsystem I did it now, so your particular problem should be fixed in r1860.

@dieterdreist: which properties window are you referring to? The detached properties editor which is usually placed to the right of the JOSM window? Then I can't reproduce it. Works for me on Win Vista. Are you running JOSM as applet or from WebStart? This could be a problem and in r1861 you should get a warning message in you console if JOSM fails to put a window always on top. Do you one of these messages in r1861?

comment:3 in reply to:  2 Changed 10 years ago by anonymous

Resolution: fixed
Status: newclosed

Replying to Gubaer:

@dieterdreist: which properties window are you referring to? The detached properties editor which is usually placed to the right of the JOSM window? Then I can't reproduce it. Works for me on Win Vista. Are you running JOSM as applet or from WebStart? This could be a problem and in r1861 you should get a warning message in you console if JOSM fails to put a window always on top. Do you one of these messages in r1861?

with properties window I intended the tag-one. It's title is properties, but actually you have the k/v pairs (tags) in a table (properties of map object). I didn't know you were still working on this, I thought it got broken unintentially and unrecognized. The version was 1857 (I updated now to r1863). In 1863 it works like a charm (on a short test). You can even put windows on top by pointing (without click) over one of the buttons (I guess that's a sideeffect of the button-image-change on mouseover and not intentially, but nice). Thank you.

comment:4 Changed 10 years ago by dieterdreist

Resolution: fixed
Status: closedreopened

sorry, I was too quick. Now I can reproduce the problem: it appears after an error. Try it yourself (detach some windows and try to upload after no modifications -> alert). After this, all windows will go under the map when activating the mapping window.

comment:5 Changed 10 years ago by Gubaer

Owner: changed from team to dieterdreist
Status: reopenedneedinfo

I've now changed all messages and dialogs to the new approach. In can't reproduce in r1866.

Can you give it another try?

comment:6 in reply to:  5 Changed 10 years ago by dieterdreist

Replying to Gubaer:

I've now changed all messages and dialogs to the new approach. In can't reproduce in r1866.

Can you give it another try?

Yes, seems OK now. There is one issue I recently noted (maybe not in conjunction with your modifications): when you click in the layers-window (detached and bigger than necessary) on the grey space below the lowest entry in order to give it focus, the lowest entry gets active (it shouldn't IMHO).

comment:7 Changed 10 years ago by Gubaer

Owner: changed from dieterdreist to Gubaer
Status: needinfonew
Summary: window order generally messed up?Layer selected when clicking in empty space in layer dialog

comment:8 Changed 10 years ago by Gubaer

fixed in r1880

comment:9 Changed 10 years ago by Gubaer

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Gubaer.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.