Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#2480 closed defect (duplicate)

Fehler mit LiveGPS

Reported by: anonymous Owned by: team
Priority: major Milestone:
Component: Plugin Version:
Keywords: Cc:

Description

Wenn ich JOSM mit LiveGPS nutzen kommt immer wieder diese Fehlermeldung:

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1555
Node Kind: directory
Last Changed Author: framm
Last Changed Rev: 1555
Last Changed Date: 2009-04-25 01:41:22 +0200 (Sat, 25 Apr 2009)

Java version: 1.6.0_13
Plugins: livegps;remotecontrol
Plugin livegps Version: 14120
Plugin remotecontrol Version: 14015

java.util.ConcurrentModificationException

at java.util.AbstractList$Itr.checkForComodification(Unknown Source)
at java.util.AbstractList$Itr.next(Unknown Source)
at org.openstreetmap.josm.data.gpx.GpxData.length(GpxData.java:113)
at org.openstreetmap.josm.gui.layer.GpxLayer.getToolTipText(GpxLayer.java:342)
at org.openstreetmap.josm.gui.dialogs.LayerListDialog$1.getListCellRendererComponent(LayerListDialog.java:179)
at javax.swing.plaf.basic.BasicListUI.paintCell(Unknown Source)
at javax.swing.plaf.basic.BasicListUI.paintImpl(Unknown Source)
at javax.swing.plaf.basic.BasicListUI.paint(Unknown Source)
at javax.swing.plaf.ComponentUI.update(Unknown Source)
at javax.swing.JComponent.paintComponent(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JViewport.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JComponent.paintToOffscreen(Unknown Source)
at javax.swing.BufferStrategyPaintManager.paint(Unknown Source)
at javax.swing.RepaintManager.paint(Unknown Source)
at javax.swing.JComponent._paintImmediately(Unknown Source)
at javax.swing.JComponent.paintImmediately(Unknown Source)
at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
at javax.swing.RepaintManager.seqPaintDirtyRegions(Unknown Source)
at javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(Unknown Source)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (12)

comment:1 Changed 10 years ago by anonymous

Here I get:
Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1629
Node Kind: directory
Last Changed Author: stoecker
Last Changed Rev: 1629
Last Changed Date: 2009-05-30 17:24:29 +0200 (Sat, 30 May 2009)

Java version: 1.6.0_0
Plugins: DirectUpload
editgpx
livegps
openstreetbugs
osmarender
surveyor
tageditor
utilsplugin
validator
wmsplugin
Plugin DirectUpload Version: 14856
Plugin editgpx Version: 14247
Plugin livegps Version: 14120
Plugin openstreetbugs Version: 14826
Plugin osmarender Version: 14406
Plugin tageditor Version: 14839
Plugin utilsplugin Version: 15127
Plugin validator Version: 15127
Plugin wmsplugin Version: 15091
Plugin surveyor Version: 14406

java.util.ConcurrentModificationException

at java.util.ArrayList$Itr.checkForComodification(ArrayList.java:782)
at java.util.ArrayList$Itr.next(ArrayList.java:754)
at org.openstreetmap.josm.data.gpx.GpxData.length(GpxData.java:127)
at org.openstreetmap.josm.gui.layer.GpxLayer.getToolTipText(GpxLayer.java:342)
at org.openstreetmap.josm.gui.dialogs.LayerListDialog$1.getListCellRendererComponent(LayerListDialog.java:179)
at javax.swing.plaf.basic.BasicListUI.paintCell(BasicListUI.java:208)
at javax.swing.plaf.basic.BasicListUI.paintImpl(BasicListUI.java:317)
at javax.swing.plaf.basic.BasicListUI.paint(BasicListUI.java:240)
at javax.swing.plaf.ComponentUI.update(ComponentUI.java:161)
at javax.swing.JComponent.paintComponent(JComponent.java:774)
at javax.swing.JComponent.paint(JComponent.java:1038)
at javax.swing.JComponent.paintChildren(JComponent.java:875)
at javax.swing.JComponent.paint(JComponent.java:1047)
at javax.swing.JViewport.paint(JViewport.java:764)
at javax.swing.JComponent.paintChildren(JComponent.java:875)
at javax.swing.JComponent.paint(JComponent.java:1047)
at javax.swing.JComponent.paintChildren(JComponent.java:875)
at javax.swing.JComponent.paint(JComponent.java:1047)
at javax.swing.JComponent.paintChildren(JComponent.java:875)
at javax.swing.JComponent.paint(JComponent.java:1047)
at javax.swing.JComponent.paintChildren(JComponent.java:875)
at javax.swing.JComponent.paint(JComponent.java:1047)
at javax.swing.JComponent.paintToOffscreen(JComponent.java:5147)
at javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:302)
at javax.swing.RepaintManager.paint(RepaintManager.java:1145)
at javax.swing.JComponent._paintImmediately(JComponent.java:5095)
at javax.swing.JComponent.paintImmediately(JComponent.java:4905)
at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:740)
at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:696)
at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:676)
at javax.swing.RepaintManager.access$700(RepaintManager.java:57)
at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1550)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:602)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

Is it the same error?

comment:2 Changed 10 years ago by stoecker

Ticket #2725 has been marked as a duplicate of this ticket.

comment:3 Changed 10 years ago by stoecker

Ticket #3238 has been marked as a duplicate of this ticket.

comment:4 Changed 10 years ago by stoecker

Ticket #3457 has been marked as a duplicate of this ticket.

comment:5 Changed 10 years ago by stoecker

Ticket #1662 has been marked as a duplicate of this ticket.

comment:6 Changed 10 years ago by stoecker

Component: unspecifiedPlugin

comment:7 Changed 10 years ago by jttt

Resolution: fixed
Status: newclosed

(In [2247]) Fixed #2480

comment:8 Changed 10 years ago by stoecker

Ticket #3829 has been marked as a duplicate of this ticket.

comment:9 Changed 10 years ago by stoecker

Resolution: fixed
Status: closedreopened

comment:10 Changed 10 years ago by casualwalker

Maybe GpxTrack.length should use the iterator from ConcurrentLinkedQueue explicitely? See
http://java.sun.com/j2se/1.5.0/docs/api/java/util/concurrent/ConcurrentLinkedQueue.html#iterator()

comment:11 Changed 10 years ago by jttt

Resolution: duplicate
Status: reopenedclosed

comment:12 Changed 10 years ago by jttt

Closed as duplicate of #4450.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.