Modify

Opened 13 years ago

Closed 13 years ago

#2426 closed defect (fixed)

"Area style way is not closed" for ways, false positives

Reported by: phobie Owned by: ulfl
Priority: minor Milestone:
Component: Internal mappaint style Version: latest
Keywords: area way closed painting Cc:

Description

The validator shows "Error: Area style way is not closed. - Painting problem" in "Warnings" for

man_made=pier
http://www.openstreetmap.org/browse/way/25798468
and

highway=pedestrian
http://www.openstreetmap.org/browse/way/14614656

Both are documented to be ways by default and only be areas if tagged with area=yes

http://wiki.openstreetmap.org/wiki/Tag:man_made=pier

http://wiki.openstreetmap.org/wiki/Tag:highway=pedestrian

Attachments (0)

Change History (11)

comment:1 Changed 13 years ago by anonymous

Also for barrier=*

comment:2 Changed 13 years ago by anonymous

Summary: "Area style way is not closed" for ways"Area style way is not closed" for ways, false positives

Same for junction=roundabout
roundabouts can be split, must somtimes even be split to handle route relations.

comment:3 Changed 13 years ago by stoecker

Component: Core validatorInternal mappaint style
Owner: changed from team to ulfl

To fix this the styles need to get a flag indicating that this type is only optionally an area. The mappaint code then can handle drawing different when way is not closed.

comment:4 Changed 13 years ago by stoecker

Ticket #2433 has been marked as a duplicate of this ticket.

comment:5 Changed 13 years ago by stoecker

Ticket #2469 has been marked as a duplicate of this ticket.

comment:6 Changed 13 years ago by stoecker

Ticket #2554 has been marked as a duplicate of this ticket.

comment:7 Changed 13 years ago by stoecker

Ticket #2582 has been marked as a duplicate of this ticket.

comment:8 Changed 13 years ago by stoecker

Ticket #2390 has been marked as a duplicate of this ticket.

comment:9 Changed 13 years ago by stoecker

Ticket #2455 has been marked as a duplicate of this ticket.

comment:10 Changed 13 years ago by stoecker

Ticket #2604 has been marked as a duplicate of this ticket.

comment:11 Changed 13 years ago by stoecker

Resolution: fixed
Status: newclosed

Fixed in r1629.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain ulfl.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.