Modify

Opened 2 months ago

Closed 8 weeks ago

Last modified 6 weeks ago

#23641 closed defect (fixed)

When mapping a forest inside a forest and make that inner, the inner landuse=forest tag is removed.

Reported by: SekeRob Owned by: team
Priority: normal Milestone: 24.04
Component: Core Version: tested
Keywords: Cc: SekeRob, Zverik

Description

Reproducible: First encountered with a named forest area with specific tree species inside a large forest MP. Regardless if directly touched or adding another inner area of any kind to the forest MP, the landuse=forest tag is removed from any 'landuse=forest' inner area. All other tags are left alone such as leaf_cycle/type, name, etc. The inner area renders blank area within the forest. Tested in ID Editor added the forest key back, then on next edit in JOSM the tag gets removed again from the inner area.

Attachments (1)

23641.patch (4.1 KB ) - added by GerdP 2 months ago.
patch and unit test

Download all attachments as: .zip

Change History (11)

comment:1 by GerdP, 2 months ago

I assume you mean the Update multipolygon action (Ctrl+Shift+B)?
At least I can reproduce it with this action with r19039.

comment:2 by SekeRob, 2 months ago

Yes, the shortcut combo. Actually not tested what happens if added via the relation toolbox... removed the forest area as member, opened RT and added. Fine. Added another non-forest inner element via the shortcut and white space on the inner forest. Any unsuspecting mapper given the note there's a dozen more inner areas to map will cause it to go blank again. When arriving first time to the named area it was already blank on Carto which is why I looked and went thru a few cycles before realizing what was going on. (I religiously visit Carto with a few Ctrl+F5 to see the map effect of the last CS).

comment:3 by GerdP, 2 months ago

It works like this since 10 years or so, I think since r5225. Both the Create and Update multipolygon action will remove the tags from the members (all of them). I wonder why nobody complained so far.
I think the solution is to not remove any tags beside an area=yes from any inner way. No unit test seems to check this so far.

Last edited 2 months ago by GerdP (previous) (diff)

by GerdP, 2 months ago

Attachment: 23641.patch added

patch and unit test

comment:4 by SekeRob, 2 months ago

I can see when doing a create it removes the tags from the polygon outline and moves them to the type=multipolygon relation. Think there's a validation rule that says there's a 'style' tags on an outline which happens when merging an MP with another polygon. We have this pop up panel now asking which tags should be proliferated to the expanded relation. In my case it's removing tags from an polygon made inner (with the shortcut). I'd not be surprised if there's a wood MP and an inner is added also of wood cause of area specificity, it makes the assumption of 'wood+wood is too much'.

comment:5 by skyper, 2 months ago

Why are the tags of a member with role inner removed?

comment:6 by GerdP, 2 months ago

Cc: Zverik added

That's the question. It was implemented like this in r5225 and never changed since.

comment:7 by GerdP, 2 months ago

Of course only those tags which are moved to the multipolygon relation are removed, and there are some exceptions, but that's what it does. I guess at that time few objects had detailed sub tags, and a hole in something with a tag X typically doesn't have tag X.

comment:8 by GerdP, 8 weeks ago

Resolution: fixed
Status: newclosed

In 19066/josm:

fix #23641: When mapping a forest inside a forest and make that inner, the inner landuse=forest tag is removed.

  • change code so the tags of inner ways which are common to the multipolygon are not removed.
  • add unit test

comment:9 by GerdP, 8 weeks ago

Milestone: 24.04

comment:10 by SekeRob, 6 weeks ago

Errata: (assuming this was the only bug fix in this JOSM release 19067 v.v. multipolygon handling) This age old bug fix had an unexpected benefit during MP relation splitting and transferring of inner areas to a new MP relation. Before it would not succeed to move inner polygons and inner multipolygon (an inner consisting of multiple parts) at the same time. Now that works great... 62 members of a 242 forest relation moved into a new separate forest MP relation. Nothing turned blank afterwards. Goodoos.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.