Modify

Opened 4 months ago

Closed 4 months ago

#23556 closed defect (duplicate)

File open dialog navigation to home directory fails for snap package

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Download any feature from OSM
  2. Select New picture from file command
  3. File open dialog navigate to root

What is the expected result?

Successful navigation to select file in home

What happens instead?

Software crashes

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2024-02-05 12:56:34 +0100 (Mon, 05 Feb 2024)
Revision:18969
Build-Date:2024-02-06 02:30:58
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (18969 en) Linux Ubuntu 22.04.4 LTS
Memory Usage: 356 MB / 3912 MB (140 MB allocated, but free)
Java version: 11.0.21+9-post-Ubuntu-0ubuntu120.04, Ubuntu, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 1920×1080 (scaling 1.00×1.00)
Maximum Screen Size: 1920×1080
Best cursor sizes: 16×16→16×16, 32×32→32×32
Environment variable LANG: en_IN
System property file.encoding: ANSI_X3.4-1968
System property sun.jnu.encoding: ANSI_X3.4-1968
Locale info: en_US
Numbers with default locale: 1234567890 -> 1234567890
Desktop environment: ubuntu:GNOME
VM arguments: [-Duser.home=${HOME}]
Dataset consistency test: No problems found

Plugins:
+ BuildingGeneralization (36)
+ ImportImagePlugin (36184)
+ Mapillary (2.2.0)
+ PicLayer (1.0.3)
+ apache-commons (36176)
+ buildings_tools (36200)
+ changeset-viewer (0.0.7)
+ ejml (36176)
+ geotools (36176)
+ jackson (36176)
+ jaxb (36118)
+ jts (36004)
+ measurement (36200)
+ reltoolbox (36217)
+ reverter (36196)
+ routing (36200)
+ undelete (36126)
+ utilsplugin2 (36200)
+ wikipedia (605)

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/Modified&zip=1

Last errors/warnings:
- 00061.213 E: Handled by bug report queue: java.nio.file.InvalidPathException: Malformed input or input contains unmappable characters: /home/<user.name>/Looking for ���the One��� Dating Apps Are Full of Polyamorous Users. - WSJ.pdf



=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: Basic L&F File Loading Thread (142)
java.nio.file.InvalidPathException: Malformed input or input contains unmappable characters: /home/arjun/Looking for ���the One��� Dating Apps Are Full of Polyamorous Users. - WSJ.pdf
	at java.base/sun.nio.fs.UnixPath.encode(UnixPath.java:145)
	at java.base/sun.nio.fs.UnixPath.<init>(UnixPath.java:69)
	at java.base/sun.nio.fs.UnixFileSystem.getPath(UnixFileSystem.java:279)
	at java.base/java.nio.file.Path.of(Path.java:147)
	at java.base/java.nio.file.Paths.get(Paths.java:69)
	at java.desktop/sun.awt.shell.ShellFolder.getShellFolder(ShellFolder.java:247)
	at java.desktop/javax.swing.filechooser.FileSystemView.getFiles(FileSystemView.java:523)
	at java.desktop/javax.swing.plaf.basic.BasicDirectoryModel$FilesLoader.run0(BasicDirectoryModel.java:300)
	at java.desktop/javax.swing.plaf.basic.BasicDirectoryModel$FilesLoader.run(BasicDirectoryModel.java:289)
	at java.base/java.lang.Thread.run(Thread.java:829)

Attachments (1)

josm file navigation to root bug.png (107.8 KB ) - added by anonymous 4 months ago.
crash window message when navigating to root

Download all attachments as: .zip

Change History (3)

by anonymous, 4 months ago

crash window message when navigating to root

comment:1 by arjunaraoc, 4 months ago

I tested with 19017 installed directly from debian repository and did not find the bug. I think the bug is only with snap version.

comment:2 by GerdP, 4 months ago

Resolution: duplicate
Status: newclosed

Closed as duplicate of #14596.
This is a common configuration problem, see e.g. #23547.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.