Modify

Opened 11 years ago

Closed 7 years ago

#2327 closed enhancement (fixed)

Plugin "Input Mask"

Reported by: Markus Baertschi <markus@…> Owned by: hampelratte
Priority: major Milestone:
Component: Plugin seamapeditor Version:
Keywords: input GUI mask validate Cc:

Description (last modified by Don-vip)

I would like to have a plugin for to work with a userfrendly input-mask:

- plugin (frame)
- get tags from JOSM-objects
- display input mask
-- listfield (not editable)
-- checkbox
-- group of radiobuttons
-- field text 
-- field floating
-- key, value, valuelist, identifier
-- icon 
- get inputs
- some receiving controls
- put all together and send it to JOSM

This will be needed by OSM sea map for to safe sea marks. The data structure of sea marks is very complicated, and not understandable for non-specialists. Therefore we need a GUI for a most user friendly help, doing all the stuff in the background.

If it works well, it would be also usable for other complex OSM-data (lanes, relation).

I'm not a programmer. But I can help by specific descriptions, and I'm able to customize the code by c+p, by designing the form and define the variables and rules.

Thanks a lot!
Markus

You can get in contact with me by mail or OSM-wiki. Partially solutions also would be helpful!

Attachments (0)

Change History (5)

comment:1 Changed 11 years ago by anonymous

This plugin "Userfriendly Input Mask" will be useful fol all appliances who needs more structured inputs. And will be helpful for specific OSM-themes like cyclemap, hikingmap, seamap ans so on.

comment:2 Changed 11 years ago by anonymous

Owner: changed from team to hampelratte

comment:4 Changed 7 years ago by Don-vip

Description: modified (diff)
Reporter: changed from anonymous to Markus Baertschi <markus@…>

comment:5 Changed 7 years ago by Don-vip

Component: PluginPlugin seamapeditor
Resolution: fixed
Status: newclosed

The SeaMapEditor plugin now provides this user-friendly interface.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain hampelratte.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.