Modify

Opened 9 years ago

Closed 9 years ago

#2293 closed defect (fixed)

memory hole in latest (slippymap)

Reported by: dieterdreist Owned by: team
Priority: blocker Milestone:
Component: Plugin Version: latest
Keywords: slippymap Cc:

Description

JOSM is "out of memory" on startup. I started JOSM, it loads slippymap (whole earth), I try to zoom in a little bit (still america and europe on the screen) and JOSM ist out of memory (more than 1,1 GB used). Deleted slippymap-layer but still.

Attachments (0)

Change History (10)

comment:1 Changed 9 years ago by stoecker

Make it reproducable.

Why does josm load the slippy map on startup?

comment:2 in reply to:  1 Changed 9 years ago by anonymous

Replying to stoecker:

Make it reproducable.

Why does josm load the slippy map on startup?

R.1487: still happening. I was not precise with startup:

  1. open JOSM (mem.-usage normal ~66MB)
  2. I go to file->new
  3. As I got slippy-map-plugin installed the slippy map loads the whole earth (very "pixely") -> mem.usage still normal
  4. I take the zoom-tool and zoom in, but not too much (lets say europe-scale)
  5. The pixels of the slippy-map-background get quite big (still no osm-data loaded)
  6. JOSM gets very very slow (mouse-movement), the hard disc rotates
  7. memory warning (strange things happen)

please note that I'm almost doing nothing: I create an empty file and zoom little bit in while slippy-map-plugin enabled. I'm sure the problem is there (it feels similar to the wms-memory-problem some weeks ago). But beside the current memory-problem: the loading mechanism for the slippy-map-bg is promising. Looks much better than the old one. Thank you

comment:3 Changed 9 years ago by stoecker

Does this also happen when you disable slippymap plugin?

comment:4 Changed 9 years ago by stoecker

Owner: changed from team to dieterdreist
Status: newneedinfo
Summary: memory hole in latestmemory hole in latest (slippymap)

comment:5 Changed 9 years ago by xeen

Ticket #2364 has been marked as a duplicate of this ticket.

comment:6 Changed 9 years ago by stoecker

Owner: changed from dieterdreist to team
Status: needinfonew

Hmm, I still ask myself if this could be integrated into WMS plugin?

comment:7 Changed 9 years ago by dieterdreist

I'm not sure if you asked something to me, but this error is not happening to me any more. But I have the slippy-map-Plugin disabled maybe since then.

comment:8 Changed 9 years ago by plaicy

Component: CorePlugin

comment:9 Changed 9 years ago by plaicy

Keywords: slippymap added

comment:10 Changed 9 years ago by anonymous

Resolution: fixed
Status: newclosed

I added some explicit management of the tile objects in the slippymap plugin. It puts a ceiling on the number of images that we keep around. That never happened before. I believe this fixed the leak.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.