Modify

Opened 13 years ago

Closed 13 years ago

#2262 closed defect (fixed)

Images fail to load using AgPifoJ plugin

Reported by: blackadder Owned by: stoecker
Priority: critical Milestone:
Component: Plugin Version: latest
Keywords: Cc:

Description

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1461
Node Kind: directory
Last Changed Author: ulfl
Last Changed Rev: 1461
Last Changed Date: 2009-03-02 23:42:54 +0100 (Mon, 02 Mar 2009)

Java version: 1.6.0_11
Plugins: AgPifoJ;measurement;openstreetbugs;osmarender;tagging-preset-tester;usertools;utilsplugin;wmsplugin
Plugin AgPifoJ Version: 13929
Plugin measurement Version: 13409
Plugin openstreetbugs Version: 13477
Plugin osmarender Version: 13448
Plugin tagging-preset-tester Version: 13585
Plugin usertools Version: 13455
Plugin utilsplugin Version: 13776
Plugin wmsplugin Version: 13927

java.lang.RuntimeException: java.lang.reflect.InvocationTargetException

at org.openstreetmap.josm.gui.PleaseWaitRunnable.closeDialog(PleaseWaitRunnable.java:146)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:95)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

Caused by: java.lang.reflect.InvocationTargetException

at java.awt.EventQueue.invokeAndWait(Unknown Source)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.closeDialog(PleaseWaitRunnable.java:142)
... 4 more

Caused by: java.lang.NullPointerException: /images/dialogs/gpx2imgManual.png not found

at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:65)
at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:173)
at org.openstreetmap.josm.gui.ExtendedDialog.setupDialog(ExtendedDialog.java:98)
at org.openstreetmap.josm.gui.ExtendedDialog.<init>(ExtendedDialog.java:47)
at org.openstreetmap.josm.plugins.agpifoj.CorrelateGpxWithImages.actionPerformed(Unknown Source)
at org.openstreetmap.josm.plugins.agpifoj.AgpifojLayer$Loader.finish(Unknown Source)
at org.openstreetmap.josm.gui.PleaseWaitRunnable$4.run(PleaseWaitRunnable.java:128)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.Dialog$1.run(Unknown Source)
at java.awt.Dialog$3.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Dialog.show(Unknown Source)
at java.awt.Component.show(Unknown Source)
at java.awt.Component.setVisible(Unknown Source)
at java.awt.Window.setVisible(Unknown Source)
at java.awt.Dialog.setVisible(Unknown Source)
at org.openstreetmap.josm.gui.PleaseWaitRunnable$3.run(PleaseWaitRunnable.java:78)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 13 years ago by xeen

Owner: changed from team to stoecker

Stöcker, could you please update the plugins once more? Apparently you checked in the update before uploading the forgotten image file :)

thanks

comment:2 Changed 13 years ago by stoecker

Resolution: fixed
Status: newclosed

Fixed in [o13985]. Added image to wrong dir.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain stoecker.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.