Modify

#22608 closed defect (worksforme)

In the geoimage viewer, closing one tab may close two tabs

Reported by: Adrian Owned by: team
Priority: normal Milestone:
Component: Core image mapping Version: latest
Keywords: template_report tab image viewer Cc:

Description

What steps will reproduce the problem?

  1. Launch JOSM or delete all layers if JOSM is already running.
  2. Load the session file from here as described at the end of ticket:21605#comment:41.
  3. Click on the third image icon, counting from the left.
  4. Click on the first image icon.
  5. Optionally, change the image by clicking on the non-selected tab.
  6. Close either the selected tab or the non-selected tab.

What is the expected result?

The tab you didn't close, remains visible.

What happens instead?

Both tabs disappear.

  1. Bring another application to the front, and then bring JOSM to the front again.

What happens?

A vestigial tab may appear.

Please provide any additional information below. Attach a screenshot if possible.

Related tickets #22606, #22607.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2022-12-21 19:35:50 +0100 (Wed, 21 Dec 2022)
Revision:18618
Build-Date:2022-12-23 02:30:59
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (18618 en_GB) Mac OS X 11.7.2
OS Build number: macOS 11.7.2 (20G1020)
Memory Usage: 434 MB / 4096 MB (131 MB allocated, but free)
Java version: 18.0.2.1+1, Azul Systems, Inc., OpenJDK 64-Bit Server VM
Look and Feel: com.apple.laf.AquaLookAndFeel
Screen: Display 1007312129 1920×1080 (scaling 1.00×1.00)
Maximum Screen Size: 1920×1080
Best cursor sizes: 16×16→16×16, 32×32→32×32
Environment variable LANG: en_GB.UTF-8
System property file.encoding: UTF-8
System property sun.jnu.encoding: UTF-8
Locale info: en_GB
Numbers with default locale: 1234567890 -> 1234567890

Plugins:
+ ImportImagePlugin (36013)
+ InfoMode (35978)
+ PicLayer (1.0.2)
+ apache-commons (36003)
+ cadastre-fr (36021)
+ editgpx (35931)
+ ejml (35924)
+ geotools (36028)
+ http2 (35921)
+ imagery_offset_db (35978)
+ jackson (36006)
+ jaxb (35952)
+ jts (36004)
+ log4j (36007)
+ measurement (35978)
+ opendata (36025)
+ photo_geotagging (35933)
+ poly (35976)
+ reverter (36011)
+ turnrestrictions (36011)
+ undelete (36011)
+ utilsplugin2 (36011)
+ waydownloader (36011)

Last errors/warnings:
- 00003.880 W: Update plug-ins - You updated your JOSM software. To prevent problems the plug-ins should be updated as well.  Update plug-ins now?
- 00030.867 E: java.io.FileNotFoundException: /Volumes/Untitled/20190909/IMG_20190909_162714.JPG (No such file or directory)
- 00049.062 E: java.io.FileNotFoundException: /Volumes/Untitled/20190914/IMG_20190914_172915.JPG (No such file or directory)
- 00062.010 E: java.io.FileNotFoundException: /Volumes/Untitled/20190909/IMG_20190909_162714.JPG (No such file or directory)

Attachments (1)

22608.gif (728.1 KB ) - added by Adrian 19 months ago.
Closing two tabs with one click

Download all attachments as: .zip

Change History (6)

comment:1 by taylor.smock, 19 months ago

I think this might be due to the same issues in #22606/#22607. I wasn't able to reproduce with the fix anyway.

Can you check and see if you can reproduce with the latest builds from https://github.com/JOSM/josm/releases (specifically r18621)?

by Adrian, 19 months ago

Attachment: 22608.gif added

Closing two tabs with one click

comment:2 by Adrian, 19 months ago

I took the.jar file for r18621 from Jenkins before you posted the link to Github. I don't expect that makes any difference.

I am still getting the same thing with r18621. That is to say, when there are two tabs, closing one of them closes both. See the animated GIF. I think that is OK if two conditions are met.

  1. It happens consistently with all session files.
  2. The converse happens when you open a session file and create tabs by clicking on image icons.

By condition 2, I mean that no tabs are created until you have clicked on image icons in two different layers, whereupon two tabs are created at the same time.
Both conditions are met with all the session files I have tried. But see a forthcoming ticket - A single click can touch multiple geoimage layers.

Closing two tabs with one click

Status report

Revision:18621
Is-Local-Build:true
Build-Date:2022-12-28 19:40:56

Identification: JOSM/1.5 (18621 SVN en_GB) Mac OS X 11.7.2
OS Build number: macOS 11.7.2 (20G1020)
Memory Usage: 522 MB / 4096 MB (187 MB allocated, but free)
Java version: 18.0.2.1+1, Azul Systems, Inc., OpenJDK 64-Bit Server VM
Look and Feel: com.apple.laf.AquaLookAndFeel
Screen: Display 1007312129 1920×1080 (scaling 1.00×1.00)
Maximum Screen Size: 1920×1080
Best cursor sizes: 16×16→16×16, 32×32→32×32
Environment variable LANG: en_GB.UTF-8
System property file.encoding: UTF-8
System property sun.jnu.encoding: UTF-8
Locale info: en_GB
Numbers with default locale: 1234567890 -> 1234567890

Plugins:
+ ImportImagePlugin (36013)
+ InfoMode (35978)
+ PicLayer (1.0.2)
+ apache-commons (36003)
+ cadastre-fr (36021)
+ editgpx (35931)
+ ejml (35924)
+ geotools (36028)
+ http2 (35921)
+ imagery_offset_db (35978)
+ jackson (36006)
+ jaxb (35952)
+ jts (36004)
+ log4j (36007)
+ measurement (35978)
+ opendata (36025)
+ photo_geotagging (35933)
+ poly (35976)
+ reverter (36011)
+ turnrestrictions (36011)
+ undelete (36011)
+ utilsplugin2 (36011)
+ waydownloader (36011)

Last errors/warnings:
- 00004.139 W: Update plug-ins - You updated your JOSM software. To prevent problems the plug-ins should be updated as well.  Update plug-ins now?
- 00074.439 E: java.io.FileNotFoundException: /Volumes/Untitled/20190909/IMG_20190909_162714.JPG (No such file or directory)
- 00076.275 E: java.io.FileNotFoundException: /Volumes/Untitled/20190914/IMG_20190914_172915.JPG (No such file or directory)

comment:3 by taylor.smock, 19 months ago

OK. That is why I didn't see the problem. I'm hiding the tabs when only one tab remains, to make certain we aren't using unnecessary vertical space on the display.

I felt that duplicating the tab information in the window title and the tab title was useless as compared to getting a bit of additional vertical space (mostly important if someone docked the window).

So 20190914 is still open. If you were to close that instead, you should see 20190909 in the window title. And loading whatever image you had selected in that layer.

in reply to:  3 comment:4 by Adrian, 19 months ago

Replying to taylor.smock:

So 20190914 is still open. If you were to close that instead, you should see 20190909 in the window title. And loading whatever image you had selected in that layer.

That is indeed what I see. I think it is OK. Hiding the tabs when one tab remains, is a good way to explain it.

comment:5 by taylor.smock, 19 months ago

Resolution: worksforme
Status: newclosed

OK. I'm going to close this as worksforme then.

BTW, thanks for the gif -- I think we would have been going back and forth for a while without that, since I was expecting the behavior that you were not.

I think it is a bit more obvious what happens when you have images loaded, but I could be wrong.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.