Modify

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2184 closed defect (wontfix)

Selecting tool roundbox is drawing too slow

Reported by: fatbozz Owned by: fatbozz
Priority: minor Milestone:
Component: unspecified Version: latest
Keywords: selecting tool, delay Cc:

Description

Hi, im using latest josm but this problem is from earlier versions. When i use select tool, then box is drawing little slightly after mouse cursor with some delay.

Attachments (0)

Change History (9)

comment:1 Changed 13 years ago by fatbozz

smaller boxes have smaller delays than big boxes.

comment:2 Changed 13 years ago by xeen

Owner: changed from framm to fatbozz
Status: newneedinfo

What's your CPU usage when selecting stuff? Which CPU do you use? Drawing the selection rectangle is pretty fast usually, so I don't know why it would be that slow.

comment:3 Changed 13 years ago by Landwirt

It's slow on my systems too. The CPU usage goes to 100% when moving the mouse while using the select box. Even on an empty layer it's slow.

comment:4 Changed 13 years ago by xeen

That's strange… is it only the select tool or is drawing/moving/zooming the map as slow?

comment:5 Changed 13 years ago by Landwirt

It's only the select tool. The problem seems to be the setXORMode function used while drawing/removing the rectangle. This function is damn slow in recent java versions, see Bug Report.

comment:6 Changed 13 years ago by xeen

Hm, not sure what we want to do about a Java Bug. Have you tried using the suggested workaround (add -Dsun.java2d.d3d=false as argument)?

comment:7 Changed 13 years ago by Landwirt

Yes, works fine with it.

I wouldn't mind and just close the ticket. :)

comment:8 Changed 13 years ago by fatbozz

Resolution: wontfix
Status: needinfoclosed

-Dsun.java2d.d3d=false | yes thats solved my problem. Im closing ticket with wontfix, its Java bug, or can Josm programmers can do better code withou XORthing :) ?

comment:9 Changed 13 years ago by anonymous

Ticket #2495 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain fatbozz.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.