Modify

Opened 13 months ago

Closed 13 months ago

Last modified 12 months ago

#21502 closed defect (fixed)

JOSM is "stealing" several file extensions after each update/installation (Windows)

Reported by: zocker22@… Owned by: Don-vip
Priority: major Milestone: 21.12
Component: Installer Windows Version: latest
Keywords: template_report regression Cc:

Description

What steps will reproduce the problem?

  1. Install JOSM (Windows version)
  2. Take a look at a file manager

What is the expected result?

If there is nothing like a checkbox during installation/update, I'd expect that all file extensions are connected to the same applications than before JOSM installation/update.

What happens instead?

After each update/installation JOSM "steals" several file extensions like .zip or .gpx even if they are connected to other applications like WinRAR. Therefore every single extension has to be corrected manually. Would you really like JOSM as default application for ZIP archives?

Please provide any additional information below. Attach a screenshot if possible.

Revision:18303
Build-Date:2021-11-01 22:53:13

Identification: JOSM/1.5 (18303 de) Windows 7 64-Bit
OS Build number: Windows 7 Ultimate (7601)
Memory Usage: 200 MB / 8184 MB (85 MB allocated, but free)
Java version: 17.0.1+12-LTS, Azul Systems, Inc., OpenJDK 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920×1200 (scaling 1.00×1.00)
Maximum Screen Size: 1920×1200
Best cursor sizes: 16×16→32×32, 32×32→32×32
System property file.encoding: Cp1252
System property sun.jnu.encoding: Cp1252
Locale info: de_DE
Numbers with default locale: 1234567890 -> 1234567890
VM arguments: [-Djpackage.app-version=1.5.18303, --add-modules=java.scripting,java.sql,javafx.controls,javafx.media,javafx.swing,javafx.web, --add-exports=java.base/sun.security.action=ALL-UNNAMED, --add-exports=java.desktop/com.sun.imageio.plugins.jpeg=ALL-UNNAMED, --add-exports=java.desktop/com.sun.imageio.spi=ALL-UNNAMED, --add-opens=java.base/java.lang=ALL-UNNAMED, --add-opens=java.base/java.nio=ALL-UNNAMED, --add-opens=java.base/jdk.internal.loader=ALL-UNNAMED, --add-opens=java.base/jdk.internal.ref=ALL-UNNAMED, --add-opens=java.desktop/javax.imageio.spi=ALL-UNNAMED, --add-opens=java.desktop/javax.swing.text.html=ALL-UNNAMED, --add-opens=java.prefs/java.util.prefs=ALL-UNNAMED, -Djpackage.app-path=%UserProfile%\AppData\Local\JOSM\JOSM.exe]

Plugins:
+ BuildingGeneralization (36)
+ buildings_tools (35823)
+ imagery_offset_db (35640)
+ pbf (35825)
+ poly (35640)
+ reverter (35732)
+ turnrestrictions (35640)
+ undelete (35640)
+ utilsplugin2 (35842)

Last errors/warnings:
- 00000.364 W: extended font config - overriding 'filename.Mongolian_Baiti=monbaiti.ttf' with 'MONBAITI.TTF'
- 00000.364 W: extended font config - overriding 'filename.Kalinga=kalinga.ttf' with 'KALINGA.TTF'
- 00000.364 W: extended font config - overriding 'filename.Iskoola_Pota=iskpota.ttf' with 'ISKPOTA.TTF'
- 00000.365 W: extended font config - overriding 'filename.Shruti=shruti.ttf' with 'SHRUTI.TTF'
- 00000.365 W: extended font config - overriding 'filename.Raavi=raavi.ttf' with 'RAAVI.TTF'
- 00000.365 W: extended font config - overriding 'filename.Gautami=gautami.ttf' with 'GAUTAMI.TTF'
- 00000.366 W: extended font config - overriding 'filename.Vrinda=vrinda.ttf' with 'VRINDA.TTF'
- 00000.366 W: extended font config - overriding 'filename.Kartika=kartika.ttf' with 'KARTIKA.TTF'
- 00000.366 W: extended font config - overriding 'filename.Latha=latha.ttf' with 'LATHA.TTF'
- 00000.973 E: java.security.KeyStoreException: Windows-ROOT not found. Ursache: java.security.NoSuchAlgorithmException: Windows-ROOT KeyStore not available

Attachments (0)

Change History (7)

comment:1 Changed 13 months ago by Don-vip

Keywords: regression added
Milestone: 21.11
Type: enhancementdefect

Damn. Of course not, it has been introduced with macOS installer (from which new Windows installer shares some code) and I didn't notice the extensions were just plain wrong.

comment:2 Changed 13 months ago by Don-vip

Owner: changed from team to Don-vip
Status: newassigned

comment:3 Changed 13 months ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 18304/josm:

fix #21502 - associate correct extensions in macOS / Windows installers, consistency for MIME types, use official osm+xml MIME type

comment:4 Changed 13 months ago by anonymous

Thanks! I didn't expect that this is a bug since it was introduced in September. But it makes sense, since in September Java has been included and therefore maybe some changes in the installer. When the new build is available I'll report if works as expected. :)

comment:5 Changed 12 months ago by Klumbumbus

Ticket #21683 has been marked as a duplicate of this ticket.

comment:6 Changed 12 months ago by Don-vip

Milestone: 21.1121.12

Milestone renamed

comment:7 Changed 12 months ago by Don-vip

In 18345/josm:

see #21502 - fix osm.xz extension

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.