Modify

Opened 14 years ago

Closed 14 years ago

#2148 closed defect (wontfix)

Absturz beim Laden neue Pluginversionen bzw. Plugins

Reported by: anonymous Owned by: framm
Priority: major Milestone:
Component: Plugin Version: tested
Keywords: Cc:

Description

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1344
Node Kind: directory
Last Changed Author: stoecker
Last Changed Rev: 1344
Last Changed Date: 2009-01-26 00:27:21 +0100 (Mon, 26 Jan 2009)

Java version: 1.6.0_07
Plugins: slippy_map_chooser,wmsplugin

java.lang.NullPointerException

at org.openstreetmap.josm.plugins.PluginDownloader.downloadPlugin(PluginDownloader.java:136)
at org.openstreetmap.josm.plugins.PluginSelection.finish(PluginSelection.java:111)
at org.openstreetmap.josm.gui.preferences.PluginPreference.ok(PluginPreference.java:117)
at org.openstreetmap.josm.gui.preferences.PreferenceDialog.ok(PreferenceDialog.java:95)
at org.openstreetmap.josm.actions.PreferencesAction.actionPerformed(PreferencesAction.java:75)
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
at javax.swing.AbstractButton.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)
at javax.swing.JComponent.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (8)

comment:1 Changed 14 years ago by stoecker

Could not reproduce. The error indicates that the a plugin-name is zero, which should not bepossible. Please try to find more information which can light up the issue a bit.

comment:2 Changed 14 years ago by anonymous

Resolution: worksforme
Status: newclosed

No answer. CLosing.

comment:3 Changed 14 years ago by anonymous

Resolution: worksforme
Status: closedreopened

comment:4 Changed 14 years ago by anonymous

See #2180.

comment:5 Changed 14 years ago by xeen

Hmm, might this be a network issue where something is not read correctly?

In any case, why don't just add a try/catch and fail silently to the console. If the user wanted a new plugin version and it fails for a "real" plugin, that's bad, but at least we lose nothing.

comment:6 Changed 14 years ago by stoecker

Plugin handling must be reworked a lot (see other plugin bugs), but I would like to find the reason for that bug in any case. I hate to fix symptoms instead of errors.

comment:7 Changed 14 years ago by xeen

#2204 has been marked as duplicate of this bug

comment:8 Changed 14 years ago by stoecker

Resolution: wontfix
Status: reopenedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.