Modify

#21325 closed defect (fixed)

JOSM app won't start on iMac

Reported by: laurens@… Owned by: Don-vip
Priority: major Milestone: 21.10
Component: Installer MacOS Version:
Keywords: regression Cc: Stereo

Description

After succesfull installation on iMac,the first start blocks.
"failing to check software, contact develloper"

Attachments (1)

Schermafbeelding 2021-09-14 om 18.00.07.png (32.4 KB) - added by laurens@… 11 months ago.
screenshot message

Download all attachments as: .zip

Change History (15)

comment:1 Changed 11 months ago by taylor.smock

Owner: changed from team to laurens@…
Status: newneedinfo

If JOSM isn't starting, can you give us the following information:

1) How you downloaded JOSM
2) The version you downloaded
3) A screenshot of the message

If JOSM is starting, we do need the JOSM status report.

Changed 11 months ago by laurens@…

screenshot message

comment:2 Changed 11 months ago by anonymous

Downloaded from your website. (https://josm.openstreetmap.de/wiki)

Tried both options, first macOS package 18193 and then the home-brew, but with same result

The App installs successfully and it shows in launchpad:

After clicking on the logo it starts to blink and after about 10 sec this massage appears.
Screenshot off the message is in Dutch:
(see screenshot)

Translated:
JOSM.app can’t be opened because Apple can’t check the file on malicious software.
The software has to be updated, contact the developer.

Info about my iMac:
Modelnaam: iMac

Modelaanduiding: iMac13,3
Processornaam: Dual-Core Intel Core i3
Processorsnelheid: 3,3 GHz
Aantal processors: 1
Totale aantal cores: 2
L2-cache (per core): 256 KB
L3-cache: 3 MB
Hyperthreading-technologie: Ingeschakeld
Geheugen: 8 GB
Opstart-ROM-versie: 422.0.0.0.0
SMC-versie (systeem): 2.10f4

Thank you for your help!

comment:3 Changed 11 months ago by taylor.smock

Cc: Stereo added
Keywords: mac added

Thank you.

@laurens: Until we figure out what is going on, a workaround would be to follow the instructions here.

@Stereo: Do you know what is going on? It looks like it is signed (codesign -dv --verbose=4 JOSM.app)?

Executable=/Applications/JOSM.app/Contents/MacOS/JOSM
Identifier=de.openstreetmap.josm
Format=app bundle with Mach-O thin (x86_64)
CodeDirectory v=20500 size=1313 flags=0x10000(runtime) hashes=32+5 location=embedded
VersionPlatform=1
VersionMin=657664
VersionSDK=659200
Hash type=sha256 size=32
CandidateCDHash sha1=5b20332d88c24a90c42334d9782d506588b254bf
CandidateCDHashFull sha1=5b20332d88c24a90c42334d9782d506588b254bf
CandidateCDHash sha256=5d25053e50b44f63e55e766e7f10beb25b364208
CandidateCDHashFull sha256=5d25053e50b44f63e55e766e7f10beb25b364208c1977fe4cf126226e0846dcb
Hash choices=sha1,sha256
CMSDigest=4b24b9751acd3afc66b5135873cac586c9f1824dcdab70391a744dcfedadf5b0
CMSDigestType=2
Page size=4096
CDHash=5d25053e50b44f63e55e766e7f10beb25b364208
Signature size=9055
Authority=Developer ID Application: FOSSGIS e.V. (P8AAAGN2AM)
Authority=Developer ID Certification Authority
Authority=Apple Root CA
Timestamp=Sep 5, 2021 at 10:26:26 AM
Info.plist entries=17
TeamIdentifier=P8AAAGN2AM
Runtime Version=10.15.0
Sealed Resources version=2 rules=13 files=187
Internal requirements count=1 size=184

comment:4 Changed 11 months ago by taylor.smock

Owner: changed from laurens@… to Stereo

comment:5 Changed 11 months ago by laurens@…

The workaround works!

thank you !!

comment:6 Changed 11 months ago by Don-vip

Milestone: 21.09
Owner: changed from Stereo to Don-vip
Status: needinfoassigned

Problem known, Stereo told me but was way too lazy to create a ticket :p

Regression from the inclusion of JavaFX library in macos package:

xcrun altool -u "xxx" -p "xxx" --notarization-info xxx

Date: 2021-09-08 22:00:16 +0000
          Hash: xxx
    LogFileURL: https://osxapps-ssl.itunes.apple.com/itunes-assets/Enigma115/v4/xxx
   RequestUUID: xxx
        Status: invalid
   Status Code: 2
Status Message: Package Invalid

The link is a json file where JavaFX binaries appear not signed or something, I don't have the json anymore and the link does not longer work, I need to run the command again.

Last edited 11 months ago by Don-vip (previous) (diff)

comment:7 Changed 11 months ago by Don-vip

Component: CoreInstaller MacOS

comment:8 Changed 11 months ago by Don-vip

Keywords: regression added; mac removed

comment:9 Changed 11 months ago by Don-vip

I just switched to Java 17 and dropped Java 16.
The Java 17 jpackage documentation has been improved a lot.

Last edited 11 months ago by Don-vip (previous) (diff)

comment:10 Changed 11 months ago by Don-vip

https://bugs.openjdk.java.net/browse/JDK-8248904?focusedCommentId=14402030&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#comment-14402030 seems related.

Maybe it just works with jpackage 17. Or maybe we just need to add the new --mac-app-store options.

comment:11 Changed 11 months ago by Don-vip

Priority: normalmajor

comment:12 Changed 10 months ago by Don-vip

Milestone: 21.0921.10

Milestone renamed

comment:13 Changed 10 months ago by Don-vip

I ran the command again on the latest build and it works now. So it was just a bug from jpackage 16:

% xcrun altool -u "xxx" -p "xxx" --notarization-info xxx
No errors getting notarization info.

          Date: 2021-10-17 14:03:16 +0000
          Hash: xxx
    LogFileURL: https://osxapps-ssl.itunes.apple.com/itunes-assets/Enigma115/v4/xxx
   RequestUUID: xxx
        Status: success
   Status Code: 0
Status Message: Package Approved
Last edited 10 months ago by Don-vip (previous) (diff)

comment:14 Changed 10 months ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 18225/josm:

see #20522 - Prefer Java 17 over everything else

also fixes #21325 (via JDK-8248904)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.