Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#21265 closed defect (fixed)

NPE in mapillary plugin

Reported by: Polarbear-j Owned by: Polarbear-j
Priority: normal Milestone:
Component: Plugin mapillary Version:
Keywords: NPE Cc:

Description

This happened while I had the mapillary filter set to 'not older than 1 year' and had trouble selecting images in the trace.

(dump follows)

Attachments (1)

debug-josm-log.gz (33.2 KB ) - added by Polarbear-j 3 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 by Polarbear-j, 3 years ago

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2021-08-26 16:42:55 +0200 (Thu, 26 Aug 2021)
Build-Date:2021-08-27 01:31:01
Revision:18182
Relative:URL: ^/trunk

Identification: JOSM/1.5 (18182 en_GB) Mac OS X 10.14.6
OS Build number: Mac OS X 10.14.6 (18G9323)
Memory Usage: 1461 MB / 3641 MB (446 MB allocated, but free)
Java version: 1.8.0_291-b10, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.apple.laf.AquaLookAndFeel
Screen: Display 69733248 1920×1200 (scaling 1.00×1.00) Display 724051919 1920×1200 (scaling 1.00×1.00)
Maximum Screen Size: 1920×1200
Best cursor sizes: 16×16→16×16, 32×32→32×32
Environment variable LANG: en_GB.UTF-8
System property file.encoding: UTF-8
System property sun.jnu.encoding: UTF-8
Locale info: en_GB
Numbers with default locale: 1234567890 -> 1234567890
Dataset consistency test: No problems found

Plugins:
+ FastDraw (35640)
+ HouseNumberTaggingTool (35640)
+ ImportImagePlugin (35567)
+ InfoMode (35543)
+ KartaView (374)
+ Mapillary (2.0.0-alpha.32-dirty)
+ PicLayer (1.0.1)
+ RoadSigns (35640)
+ apache-commons (35524)
+ apache-http (35589)
+ areaselector (368)
+ austriaaddresshelper (1597341117)
+ buildings_tools (35756)
+ changeset-viewer (25)
+ continuosDownload (99)
+ ejml (35458)
+ geotools (35458)
+ imagery-xml-bounds (35723)
+ jaxb (35543)
+ jna (35662)
+ jogl (1.2.3)
+ jts (35458)
+ kendzi3d (1.0.205)
+ kendzi3d-resources (0.0.2)
+ log4j (35458)
+ measurement (35640)
+ photo_geotagging (35783)
+ photoadjust (35770)
+ print (35640)
+ reltoolbox (35640)
+ reverter (35732)
+ tageditor (35640)
+ terracer (35640)
+ turnlanes-tagging (288)
+ turnrestrictions (35640)
+ undelete (35640)
+ utilsplugin2 (35792)
+ waydownloader (35640)
+ wikipedia (1.1.4)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&preset
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&preset
+ https://josm.openstreetmap.de/josmfile?page=Presets/Playground_Equipment&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Community_Centre&zip=1
+ https://github.com/kendzi/Simple3dBuildingsPreset/releases/download/0.9_2018-05-08/s3db-preset.zip

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_features&style
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_features_ryg&style
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&style
- https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&style
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_buildings&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&zip=1
- https://github.com/simon04/coloured-addresses.mapcss/raw/master/dist/coloured-addresses.mapcss

Last errors/warnings:
- 00022.457 E: Failed to locate image 'preference.png'
- 01439.773 W: java.net.SocketTimeoutException: Read timed out. Cause: java.net.SocketTimeoutException: Read timed out
- 01462.468 E: java.lang.NullPointerException
- 01462.482 E: Handled by bug report queue: java.lang.NullPointerException
- 01462.670 E: java.lang.NullPointerException
- 01462.868 E: java.lang.NullPointerException
- 01463.078 E: java.lang.NullPointerException
- 01463.176 E: Handled by bug report queue: java.lang.NullPointerException
- 01463.205 E: Handled by bug report queue: java.lang.NullPointerException
- 01463.223 E: Handled by bug report queue: java.lang.NullPointerException



=== REPORTED CRASH DATA ===
JsonDecoder#lambda$decodeData$0:
 - json: {"data":[{"altitude":75.864,"thumb_2048_url":"https://scontent-ber1-1.xx.fbcdn.net/m1/v/t6/An_2FVQ_oXXPE-65YvkjFJVlMQ7jcTEzk5V00oYTqrMBF6mO017_3y90x4rWZWz4IxiATDH30CqW8Bbf8OBAtA5N6WANkL_vb25bWJ6wUxGP5CiY3T7FhaZCIc-SxmQOdHKEp7eXAsnTttFwiqwJJA?stp=s2048x1536&ccb=10-5&oh=df4aa3e8d5d2197801b0e86e4e5b9bfd&oe=6132A7B9&_nc_sid=122ab1","captured_at":1622825444500,"compass_angle":0,"exif_orientation":1,"geometry":

****** The ticket system complains about too many external links and rejects as spam. If needed I can submit the rest as archive. ******



=== STACK TRACE ===
Thread: AWT-EventQueue-0 (20) of main
java.lang.NullPointerException
	at org.openstreetmap.josm.plugins.mapillary.utils.api.JsonImageDetailsDecoder.decodeImageInfo(JsonImageDetailsDecoder.java:97)
	at org.openstreetmap.josm.plugins.mapillary.utils.api.JsonImageDetailsDecoder.lambda$decodeImageInfos$0(JsonImageDetailsDecoder.java:71)
	at java.util.stream.ReferencePipeline$3$1.accept(ReferencePipeline.java:193)
	at java.util.ArrayList$ArrayListSpliterator.forEachRemaining(ArrayList.java:1384)
	at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:482)
	at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:472)
	at java.util.stream.ReduceOps$ReduceOp.evaluateSequential(ReduceOps.java:708)
	at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234)
	at java.util.stream.ReferencePipeline.collect(ReferencePipeline.java:499)
	at org.openstreetmap.josm.plugins.mapillary.utils.api.JsonImageDetailsDecoder.decodeImageInfos(JsonImageDetailsDecoder.java:72)
	at org.openstreetmap.josm.plugins.mapillary.io.download.MapillaryDownloader.lambda$realDownloadImages$1(MapillaryDownloader.java:97)
	at org.openstreetmap.josm.plugins.mapillary.utils.api.JsonDecoder.decodeData(JsonDecoder.java:94)
	at org.openstreetmap.josm.plugins.mapillary.io.download.MapillaryDownloader.realDownloadImages(MapillaryDownloader.java:96)
	at org.openstreetmap.josm.plugins.mapillary.io.download.MapillaryDownloader.downloadImages(MapillaryDownloader.java:63)
	at org.openstreetmap.josm.plugins.mapillary.utils.api.JsonSequencesDecoder.decodeSequence(JsonSequencesDecoder.java:67)
	at org.openstreetmap.josm.plugins.mapillary.utils.api.JsonDecoder.decodeData(JsonDecoder.java:94)
	at org.openstreetmap.josm.plugins.mapillary.utils.MapillarySequenceUtils.downloadSequence(MapillarySequenceUtils.java:206)
	at org.openstreetmap.josm.plugins.mapillary.utils.MapillarySequenceUtils.getSequence(MapillarySequenceUtils.java:170)
	at org.openstreetmap.josm.plugins.mapillary.gui.MapillaryMainDialog.lambda$setImage$10(MapillaryMainDialog.java:619)
	at java.util.concurrent.ForkJoinTask$RunnableExecuteAction.exec(ForkJoinTask.java:1402)
	at java.util.concurrent.ForkJoinTask.doExec(ForkJoinTask.java:289)
	at java.util.concurrent.ForkJoinPool$WorkQueue.runTask(ForkJoinPool.java:1067)
	at java.util.concurrent.ForkJoinPool.runWorker(ForkJoinPool.java:1703)
	at java.util.concurrent.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:172)

comment:2 by taylor.smock, 3 years ago

Owner: changed from taylor.smock to Polarbear-j
Status: newneedinfo

I fixed this today. :)

The problem was in JOSM core (my fault), and was due to me misreading a math equation.

I have been intending to release a workaround for older JOSM versions (currently blocked behind a failing test -- I need to debug that).

I do need the json line.
- json: {"data":[{"altitude":75.864,"thumb_2048_url":"https://scontent-ber1-1.xx.fbcdn.net/m1/v/t6/An_2FVQ_oXXPE-65YvkjFJVlMQ7jcTEzk5V00oYTqrMBF6mO017_3y90x4rWZWz4IxiATDH30CqW8Bbf8OBAtA5N6WANkL_vb25bWJ6wUxGP5CiY3T7FhaZCIc-SxmQOdHKEp7eXAsnTttFwiqwJJA?stp=s2048x1536&ccb=10-5&oh=df4aa3e8d5d2197801b0e86e4e5b9bfd&oe=6132A7B9&_nc_sid=122ab1","captured_at":1622825444500,"compass_angle":0,"exif_orientation":1,"geometry":
The problem is that the geometry (probably computed?) had a null value.

Last edited 3 years ago by taylor.smock (previous) (diff)

by Polarbear-j, 3 years ago

Attachment: debug-josm-log.gz added

comment:3 by Polarbear-j, 3 years ago

yup, attached the full dump with tons of such URLs as .gz file

comment:4 by Polarbear-j, 3 years ago

so the fix will be in today's daily JOSM, or in the plugin?

in reply to:  4 comment:5 by taylor.smock, 3 years ago

Replying to Polarbear-j:

so the fix will be in today's daily JOSM, or in the plugin?

The fix for #21254 will be in the JOSM-latest.jar (whenever that is generated), and I'm hoping to have the workaround for earlier versions in the plugin today.

For this ticket, I'll try to get the fix out in the plugin today.

comment:6 by taylor.smock, 3 years ago

Resolution: fixed
Status: needinfoclosed

Fixed in cd8b3fdc830495fce6a4fffdee1d012a7180e3a9. Not yet released -- depends upon pipeline passing, and there is a flaky test I need to debug.

I'll try to get it out today, and I'll come back and update this ticket when that happens.

comment:7 by taylor.smock, 3 years ago

I've done a release. Please wait ~10 minutes before updating (that is about how long it takes for the JOSM servers to parse the updated jar file and get the new version number).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Polarbear-j.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.