Modify

Opened 13 years ago

Closed 13 years ago

#2112 closed enhancement (fixed)

[PATCH] define scale or zoom level by number

Reported by: Schusch Owned by: framm
Priority: minor Milestone:
Component: unspecified Version:
Keywords: Cc:

Description

It would still be great to have the possibility to select a special scale (zoom-factor) supported by keyboard to have reproducable big parts of the map shown. There should be a command in the view menu or a possibility like i suggested in #1454 (define the scale by clicking on the ruler and entering a number).

The ruler control is much better now (thanks :-) but I still can't zoom to a reproducable level (like e. g. 200 m)

Attachments (1)

AddScaleField.zip (1.9 KB) - added by xeen 13 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 13 years ago by xeen

What would be the advantage of being able to zoom to a specified level?

comment:2 Changed 13 years ago by Schusch

to get a reproducable segment of the map (or what is the scale else for?) I would prefere getting this by scale and not by coordinates which are much more unintentionally. It's for the same reason why openstreetmap and for example google have this ruler on the side, where I can choose the zoom level. It's more precise if I can define the scale by number than just a zoom level. I can get a special scale now too--but only nearly the same as before ... or I have to zoom in and out until I get the same scale.

comment:3 Changed 13 years ago by xeen

I've always used the scale as an orientation to see how large stuff actually is. OSM and Google use the zoom level scheme because it's not possible yet to render the maps in the browser and that the pre-rendered images cannot be provided in every zoom. Also, unless you specifically compare map renderings in an image software, what's the difference between say 200 m and 210 m?

comment:4 in reply to:  3 Changed 13 years ago by anonymous

Replying to xeen:

what's the difference between say 200 m and 210 m?

no problem with one of both - as long as I have an easy way to reproduce the same size the next time to get a comparable section of the map (yes the 200 m and the 210 m pane are nearly the same - but why don't give a possibility for the exact same scale) - it's an enhancement (!) which I would really appreciate and I think some more people would use it, if it is there :-)

Changed 13 years ago by xeen

Attachment: AddScaleField.zip added

comment:5 Changed 13 years ago by xeen

Summary: define scale or zoom level by number[PATCH] define scale or zoom level by number

Well, you convinced me.

This patch updates utilplugin's "Jump To" dialog to support zoom values. It supports conversion from OSM URL to zoom level in metres and vice-versa. If you want to zoom to say 100 m, just hit CTRL + G (or click the lon / lat in the lower left corner), change zoom level and hit enter.

comment:6 in reply to:  5 Changed 13 years ago by Schusch

This patch updates utilplugin's "Jump To" dialog to support zoom values.

great news :-) thanks in advance

comment:7 in reply to:  5 Changed 13 years ago by anonymous

hm, how to use it?

I updated the utilsplugin and also deleted and downloaded it again but I don't see a possibility to enter a scale - only the coordinates or an url - did I miss something?

comment:8 Changed 13 years ago by anonymous

Resolution: fixed
Status: newclosed

Applied in 13575 of utilsplugin.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.