Modify

Opened 3 years ago

Closed 3 years ago

Last modified 23 months ago

#20917 closed defect (duplicate)

Error updating the building tools plug in

Reported by: EmilyBA Owned by: team
Priority: normal Milestone:
Component: Plugin buildings_tools Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2021-04-27 20:35:33 +0200 (Tue, 27 Apr 2021)
Build-Date:2021-04-27 21:58:39
Revision:17833
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17833 en_GB) Windows 10 64-Bit
OS Build number: Windows 10 Home 1909 (18363)
Memory Usage: 1597 MB / 3598 MB (1005 MB allocated, but free)
Java version: 1.8.0_291-b10, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920×1080 (scaling 1.00×1.00)
Maximum Screen Size: 1920×1080
Best cursor sizes: 16×16→32×32, 32×32→32×32
System property file.encoding: Cp1252
System property sun.jnu.encoding: Cp1252
Locale info: en_GB
Numbers with default locale: 1234567890 -> 1234567890
Dataset consistency test: No problems found

Plugins:
+ BuildingGeneralization
+ CADTools (1008)
+ buildings_tools (35740)
+ centernode (v1.0.4)
+ changeset-viewer (25)
+ imagery_offset_db (35640)
+ utilsplugin2 (35691)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1

Last errors/warnings:
- 00156.316 E: Bad Request - <html>The OSM server 'api.openstreetmap.org' reported a bad request.<br><br>The area you tried to download is too big or your request was too large.<br>Either request a smaller area or use an export file provided by the OSM community.</html>
- 00345.540 E: Handled by bug report queue: java.lang.IllegalArgumentException: Listener org.openstreetmap.josm.plugins.buildings_tools.DrawBuildingAction@31cb353d (instance of org.openstreetmap.josm.plugins.buildings_tools.DrawBuildingAction) was not registered before or already removed.
- 00400.049 E: org.openstreetmap.josm.plugins.PluginDownloadException: java.io.IOException: stream is closed. Cause: java.io.IOException: stream is closed
- 00413.446 E: Handled by bug report queue: java.lang.IllegalArgumentException: Listener org.openstreetmap.josm.plugins.buildings_tools.DrawBuildingAction@31cb353d (instance of org.openstreetmap.josm.plugins.buildings_tools.DrawBuildingAction) was not registered before or already removed.
- 00451.301 E: Handled by bug report queue: java.lang.IllegalArgumentException: Listener org.openstreetmap.josm.plugins.buildings_tools.DrawBuildingAction@31cb353d (instance of org.openstreetmap.josm.plugins.buildings_tools.DrawBuildingAction) was not registered before or already removed.
- 00512.253 E: Handled by bug report queue: java.lang.IllegalArgumentException: Listener org.openstreetmap.josm.plugins.buildings_tools.DrawBuildingAction@31cb353d (instance of org.openstreetmap.josm.plugins.buildings_tools.DrawBuildingAction) was not registered before or already removed.
- 00545.164 E: Handled by bug report queue: java.lang.IllegalArgumentException: Listener org.openstreetmap.josm.plugins.buildings_tools.DrawBuildingAction@31cb353d (instance of org.openstreetmap.josm.plugins.buildings_tools.DrawBuildingAction) was not registered before or already removed.
- 00623.798 E: Handled by bug report queue: java.lang.IllegalArgumentException: Listener org.openstreetmap.josm.plugins.buildings_tools.DrawBuildingAction@31cb353d (instance of org.openstreetmap.josm.plugins.buildings_tools.DrawBuildingAction) was not registered before or already removed.
- 00626.876 E: Handled by bug report queue: java.lang.IllegalArgumentException: Listener org.openstreetmap.josm.plugins.buildings_tools.DrawBuildingAction@31cb353d (instance of org.openstreetmap.josm.plugins.buildings_tools.DrawBuildingAction) was not registered before or already removed.
- 00648.377 E: Handled by bug report queue: java.lang.IllegalArgumentException: Listener org.openstreetmap.josm.plugins.buildings_tools.DrawBuildingAction@31cb353d (instance of org.openstreetmap.josm.plugins.buildings_tools.DrawBuildingAction) was not registered before or already removed.



=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (19) of main
java.lang.IllegalArgumentException: Listener org.openstreetmap.josm.plugins.buildings_tools.DrawBuildingAction@31cb353d (instance of org.openstreetmap.josm.plugins.buildings_tools.DrawBuildingAction) was not registered before or already removed.
	at org.openstreetmap.josm.tools.ListenerList.failRemove(ListenerList.java:137)
	at org.openstreetmap.josm.tools.ListenerList.removeListener(ListenerList.java:131)
	at org.openstreetmap.josm.data.Preferences.removePreferenceChangeListener(Preferences.java:261)
	at org.openstreetmap.josm.actions.mapmode.MapMode.exitMode(MapMode.java:86)
	at org.openstreetmap.josm.plugins.buildings_tools.DrawBuildingAction.exitMode(DrawBuildingAction.java:163)
	at org.openstreetmap.josm.gui.MapFrame.activeOrEditLayerChanged(MapFrame.java:854)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.fireActiveLayerChange(MainLayerManager.java:271)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.setActiveLayer(MainLayerManager.java:264)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.realSetActiveLayer(MainLayerManager.java:248)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.lambda$setActiveLayer$1(MainLayerManager.java:241)
	at org.openstreetmap.josm.gui.util.GuiHelper.runInEDTAndWaitWithException(GuiHelper.java:246)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.setActiveLayer(MainLayerManager.java:241)
	at org.openstreetmap.josm.gui.dialogs.layer.ActivateLayerAction.execute(ActivateLayerAction.java:86)
	at org.openstreetmap.josm.gui.dialogs.layer.ActivateLayerAction.actionPerformed(ActivateLayerAction.java:81)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.AbstractButton.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (1)

Error.PNG (968.9 KB ) - added by EmilyBA 3 years ago.

Download all attachments as: .zip

Change History (3)

by EmilyBA, 3 years ago

Attachment: Error.PNG added

comment:1 by simon04, 3 years ago

Resolution: duplicate
Status: newclosed

Closed as duplicate of #17465.

comment:2 by skyper, 23 months ago

Component: CorePlugin buildings_tools

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.