Modify

Opened 5 months ago

Closed 4 weeks ago

#20911 closed defect (duplicate)

Validator incorrectly reports overlapping buildings for building and building:part that share nodes

Reported by: jpear1 Owned by: team
Priority: normal Milestone:
Component: Core validator Version:
Keywords: template_report overlapping buildings Cc:

Description

What steps will reproduce the problem?

  1. Download attached reproduce.osm
  2. Launch JOSM and open reproduce.osm
  3. Run the validator

What is the expected result?

No warnings

What happens instead?

One warning: Overlapping buildings

Please provide any additional information below. Attach a screenshot if possible.

I encountered this warning editing the UCSB Library, located at about 34.4135, -119.8455. I removed a lot of the junk around it to make it easier to look at.

This warning seems to come and go. If you copy all of the data in reproduce.osm and paste it into a new layer, the warning goes away. Sometimes I could simplify the shape more and still get this validator warning, but it would disappear once I saved the file, closed and repoened JOSM, reopened the file, and re-ran the validator.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2021-04-27 20:35:33 +0200 (Tue, 27 Apr 2021)
Revision:17833
Build-Date:2021-04-27 21:58:39
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (17833 en) Linux Arch Linux
Memory Usage: 169 MB / 1922 MB (76 MB allocated, but free)
Java version: 15.0.2+7, N/A, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 1920×1080 (scaling 1.00×1.00) :0.1 1920×1080 (scaling 1.00×1.00)
Maximum Screen Size: 1920×1080
Best cursor sizes: 16×16→16×16, 32×32→32×32
Environment variable LANG: en_US.UTF-8
System property file.encoding: UTF-8
System property sun.jnu.encoding: UTF-8
Locale info: en_US
Numbers with default locale: 1234567890 -> 1234567890
Desktop environment: KDE
VM arguments: [-Djosm.restart=true]
Dataset consistency test: No problems found

Plugins:
+ apache-commons (35524)
+ conflation (0.6.6)
+ ejml (35458)
+ geotools (35458)
+ imagery_offset_db (35640)
+ jaxb (35543)
+ jts (35458)
+ opendata (35640)
+ turnrestrictions (35640)
+ utilsplugin2 (35691)

Attachments (2)

overlapping_buildings.png (108.6 KB) - added by jpear1 5 months ago.
screenshot of warning and data
reproduce.osm (41.3 KB) - added by jpear1 5 months ago.
data to reproduce incorrect warning

Download all attachments as: .zip

Change History (5)

Changed 5 months ago by jpear1

Attachment: overlapping_buildings.png added

screenshot of warning and data

Changed 5 months ago by jpear1

Attachment: reproduce.osm added

data to reproduce incorrect warning

comment:1 Changed 5 months ago by skyper

Keywords: overlapping buildings added

Mmh, I remember similar problem in the past. Is this a duplicate of #20054?

If you select both ways and orthogonalize them the warning goes away but if you move the shared node in the southeastern corner a little bit to the south it comes back.

@jpear1:
Deleting is dangerous and all objects are still present in the file. Next time, better use purge or create a new layer and merge the selected objects into it.

comment:2 Changed 5 months ago by jpear1

I'm not sure. It seems related, but I downloaded josm_area_inside_area_shared_segment.osm​ from that bug report and didn't get any warnings.

And good to know on the deleted objects hanging around.

comment:3 Changed 4 weeks ago by GerdP

Resolution: duplicate
Status: newclosed

Closed as duplicate of #20054.
> Mmh, I remember similar problem in the past. Is this a duplicate of #20054?
Yes, rotating the objects 180° also removes the warning.

I'm not sure. It seems related, but I downloaded josm_area_inside_area_shared_segment.osm​ from that bug report and didn't get any warnings.

You probably didn't enable "show informational level" for validator.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.