Modify

Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#2086 closed defect (fixed)

When splitting a way, that is member of a turn restriction, the part that is not connected to the via-node is still part of the relation

Reported by: Torstiko Owned by: framm
Priority: major Milestone:
Component: unspecified Version: tested
Keywords: Turn Restriction Relation Cc:

Description

When splitting a way, that is member of a turn restriction, the part that is not connected to the via-node is still part of the relation.

Wenn man einen Weg, der Teil einer Abbiegevorschrift ist (zb restriction:only_straight_on) teilt, so ist das Teilstück, das nicht mit dem via-node verbunden ist immernoch Teil der Relation. Das macht keinen Sinn. Zwar kommt eine Meldung, dass man Relationen und Mitglieder überprüfen soll, jedoch lässt jemand unwissendes meist die Finger davon, womit es dann 2 "from" oder "to" Mitglieder gibt.

Attachments (0)

Change History (9)

comment:1 Changed 13 years ago by anonymous

As long as we have no specific relation handling this is a wontfix. We can add some workarounds now, but I would prefer to have a generic system.

comment:2 Changed 13 years ago by ulfl

Ticket #2764 has been marked as a duplicate of this ticket.

comment:3 Changed 13 years ago by plaicy

Ticket #2790 has been marked as a duplicate of this ticket.

comment:4 Changed 13 years ago by fidoez

Priority: minornormal

With the redesign of the relation editor and the increasing importance of relations it could be worth to increase the priority of this ticket.

comment:5 Changed 13 years ago by fidoez

  1. also #3507

comment:6 Changed 13 years ago by stoecker

Ticket #3507 has been marked as a duplicate of this ticket.

comment:7 Changed 12 years ago by AM909

Priority: normalmajor
Version: latesttested

I'm taking great care to survey and map turn restrictions in my area. Unfortunately, the more restrictions I create in the area, the harder it is to create new ones, since splitting a way now often results in broken restrictions. I can't even find an easy workaround, other than to write down all the id numbers before hand so I know which ones to fix. This multiplies the time taken to map a single restriction (which is still not ideal) by many times.

This seems to me a simple fix - do not copy to or from relations where type=restriction when splitting a way.

comment:8 Changed 12 years ago by stoecker

Resolution: fixed
Status: newclosed

(In [2628]) close #2086 - handle restriction relation for way splitting

comment:9 Changed 12 years ago by stoecker

It was no simple fix, as you need to find out which of the splitted ways needs to get the role.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.