Opened 3 years ago

Last modified 3 years ago

#20778 reopened defect

TMS server cache

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core imagery Version: latest
Keywords: tms cache invalidate clear Cc:


i have this TMS server that updated every 10 minutes, and i did try to flush its cache from layer window and clear cache from imagery setting and re adding it and can not clear cache and if you zoom in or out you will see the new tiles, i hope can any one fix that,the TMS server:{z}/{x}/{y}/2/1_0.png

for more see:

Attachments (0)

Change History (10)

comment:1 Changed 3 years ago by anonymous

Ticket #20779 has been marked as a duplicate of this ticket.

comment:2 Changed 3 years ago by skyper

Component: Plugin imagerycacheCore imagery
Owner: changed from akks to team

Thanks for your report, however your ticket is incomplete and therefore not helpful in its current form.

Please add all needed information according to this list:

  • The required parts of the Status Report from your JOSM.
  • Describe what behaviour you expected.
  • Describe what did happen instead.
  • Describe if and how the issue is reproducible.
  • Add any relevant information like error messages or screenshots.

To ensure that all technical relevant information is contained, create new tickets by clicking in JOSMs Main Menu on Helpsource:trunk/resources/images/bug.svg Report Bug.

comment:3 Changed 3 years ago by anonymous

What steps will reproduce the problem?

  1. add TMS tile: ​{z}/{x}/{y}/2/1_0.png that refresh every 10 minutes
  2. add it to layer
  3. after 10 minutes i did flush cache of this TMS tile
  4. it's load again from cache not the new tile from server

What is the expected result?

get the new tile and clear cache of tile

What happens instead?

did not update the tiles from server

Please provide any additional information below. Attach a screenshot if possible.

Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2021-04-01 23:17:01 +0200 (Thu, 01 Apr 2021)
Build-Date:2021-04-01 21:46:03
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17702 en) Windows 10 64-Bit
OS Build number: Windows 10 Pro 2009 (19042)
Memory Usage: 568 MB / 1820 MB (495 MB allocated, but free)
Java version: 1.8.0_281-b09, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel:
Screen: \Display0 1680×1050 (scaling 1.00×1.00)
Maximum Screen Size: 1680×1050
Best cursor sizes: 16×16→32×32, 32×32→32×32
System property file.encoding: Cp1256
System property sun.jnu.encoding: Cp1256
VM arguments: [,<java.home>\lib\security\javaws.policy, -DtrustProxy=true, -Djnlpx.home=<java.home>\bin, -Djnlpx.origFilenameArg=%UserProfile%\AppData\LocalLow\Sun\Java\Deployment\cache\6.0\56\1ee8cfb8-3988367f, -Djnlpx.remove=false, -Djava.util.Arrays.useLegacyMergeSort=true, -Djnlpx.heapsize=NULL,2048m, -Djnlpx.splashport=54142, -Djnlp.application.href=, -Djnlpx.jvm=<java.home>\bin\javaw.exe]

+ FastDraw (35640)
+ PicLayer (2a9aa7a)
+ PolygonCutOut (v0.7)
+ SaudiNationalAddress (35640)
+ apache-commons (35524)
+ ejml (35458)
+ geotools (35458)
+ jaxb (35543)
+ jts (35458)
+ log4j (35458)
+ mbtiles (v2.6.1)
+ merge-overlap (35640)
+ o5m (35640)
+ opendata (35640)
+ pbf (35720)
+ pdfimport (35640)
+ poly (35640)
+ rasterfilters (35648)
+ reltoolbox (35640)
+ reverter (35688)
+ terracer (35640)
+ undelete (35640)
+ utilsplugin2 (35691)

Map paint styles:
- %UserProfile%\Downloads\mapnik\mapnik.mapcss

Last errors/warnings:
- 00002.643 W: Unable to request certificate of
- 00003.024 W: Unable to request certificate of

comment:4 in reply to:  2 Changed 3 years ago by anonymous

Last edited 3 years ago by simon04 (previous) (diff)

comment:5 Changed 3 years ago by simon04

Keywords: tms cache invalidate clear added

comment:6 Changed 3 years ago by simon04

You might want/need to set minimum-tile-expire (the default is one hour, see Maps) to let JOSM handle the tile expiration.

comment:7 Changed 3 years ago by anonymous

thank you very much it worked after i set:
imagery.generic.minimum_expires" value="10000
minimumTileExpire" value="20000"/> #for imagery layer

comment:8 Changed 3 years ago by anonymous

Resolution: fixed
Status: newclosed

comment:9 Changed 3 years ago by anonymous

Resolution: fixed
Status: closedreopened

Unfortunately, the problem came back and changing the zoom made me think that the problem was solved, because changing the zoom level will show you the recent image, but at the same level of magnification it does not update even if you clear the cache.

comment:10 Changed 3 years ago by anonymous

I noticed that sometimes the problem is solved, sometimes not it might be from weather maps api not from JOSM

Modify Ticket

Change Properties
Set your email in Preferences
as reopened The owner will remain team.
as The resolution will be set.
to The owner will be changed from team to the specified user.
The owner will change to anonymous
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.