Modify

Opened 15 months ago

Closed 12 months ago

Last modified 12 months ago

#20637 closed enhancement (fixed)

[Patch] Detection of role=*

Reported by: jervinsevilla175@… Owned by: team
Priority: normal Milestone: 21.06
Component: Core validator Version:
Keywords: template_report role Cc:

Description

What steps will reproduce the problem?

  1. Add role=* to an object
  2. Run the JOSM validator

What is the expected result?

The validator should detect that the role key is being used and issue a warning or an error.

What happens instead?

The validator does not warn that role=* is being used.

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-12-28 22:03:23 +0100 (Mon, 28 Dec 2020)
Build-Date:2020-12-29 02:30:53
Revision:17428
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17428 en) Windows 10 64-Bit
OS Build number: Windows 10 Home 2009 (19042)
Memory Usage: 912 MB / 989 MB (156 MB allocated, but free)
Java version: 1.8.0_281-b09, Oracle Corporation, Java HotSpot(TM) Client VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920×1080 (scaling 1.00×1.00)
Maximum Screen Size: 1920×1080
Best cursor sizes: 16×16→32×32, 32×32→32×32
Dataset consistency test: No problems found

Plugins:
+ ShapeTools (1240)
+ apache-commons (35524)
+ apache-http (35589)
+ areaselector (368)
+ austriaaddresshelper (1597341117)
+ ejml (35458)
+ gridify (1606242219)
+ imagery_offset_db (35640)
+ jna (35662)
+ log4j (35458)
+ mapwithai (1.7.1.3)
+ reltoolbox (35640)
+ turnrestrictions (35640)
+ utilsplugin2 (35691)
+ wms-turbo-challenge2 (35562)

Tagging presets:
+ https://raw.githubusercontent.com/osmlab/name-suggestion-index/main/dist/presets/nsi-josm-presets.min.xml

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/MapWithAI&zip=1

Last errors/warnings:
- 94923.304 E: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException: 3
- 94923.320 E: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException: 3
- 94923.320 E: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException: 3
- 94923.336 E: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException: 3
- 94923.336 E: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException: 3
- 94923.351 E: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException: 3
- 94923.351 E: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException: 3
- 94923.414 E: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException: 3
- 95049.519 E: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException: 3
- 95050.332 E: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException: 3

Attachments (0)

Change History (6)

comment:1 Changed 15 months ago by jervinsevilla175@…

Summary: Dectection of role=*Detection of role=*

comment:2 Changed 15 months ago by skyper

Something similar to below needs to be added to geometry.macss, I guess.

/* {0} on object, should be in member list */
*[role] {
  throwWarning: tr("{0} on object, {1} is specified in relation's member list only.", "{0.tag}", "{0.key}");
  assertMatch: "node role=stop";
}

comment:3 Changed 15 months ago by skyper

Ticket #20636 has been marked as a duplicate of this ticket.

comment:4 Changed 12 months ago by skyper

Keywords: role added
Milestone: 21.06
Summary: Detection of role=*[Patch] Detection of role=*

comment:5 Changed 12 months ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 17956/josm:

fix #20637 - Warn about role as a tag (patch by skyper)

comment:6 Changed 12 months ago by Don-vip

In 17959/josm:

see #20637 - fix i18n

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.