Modify

#20571 closed enhancement (fixed)

role entry fields should automatically remove leading/trailing spaces

Reported by: anonymous Owned by: Don-vip
Priority: normal Milestone: 21.02
Component: Core Version:
Keywords: relation role Cc:

Description

What steps will reproduce the problem?

create a relation type=waterway, add a way with role "main_stream "
upload

What is the expected result?

warning and/or remove leading/trailing spaces

What happens instead?

no warning, no fix

Attachments (0)

Change History (7)

comment:1 Changed 15 months ago by skyper

Keywords: relation role added

+1

Similar to tags, the leading/trailing white spaces/tabs should be removed automatically when adding roles. Additionally, for modified relations, any role could be check and adjusted, automatically, before upload.

comment:2 Changed 15 months ago by Don-vip

Owner: changed from team to Don-vip
Status: newassigned

comment:3 Changed 15 months ago by Don-vip

Milestone: 21.02
Type: defectenhancement

comment:4 Changed 15 months ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 17555/josm:

fix #20571 - strip leading/trailing whitespace from roles entered in relation editor

comment:5 Changed 15 months ago by skyper

Resolution: fixed
Status: closedreopened

You can edit roles directly from property panel since some months by clicking on the role entry. There it is also possible to add white spaces.

comment:6 in reply to:  5 Changed 15 months ago by skyper

Replying to skyper:

You can edit roles directly from property panel since some months by clicking on the role entry. There it is also possible to add white spaces.

See RelationRoleEditor.java

comment:7 Changed 15 months ago by Don-vip

Resolution: fixed
Status: reopenedclosed

In 17557/josm:

fix #20571 - strip leading/trailing whitespace from roles entered in property panel

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.