Modify

Opened 14 years ago

Closed 13 years ago

Last modified 21 months ago

#2056 closed defect (wontfix)

Prevent changes when zoom level display is used

Reported by: dieterdreist Owned by: team
Priority: major Milestone:
Component: Core Version: latest
Keywords: zooming Cc:

Description

Currently, if you start with an empty layer (scale 458 km in view), you can add nodes but you can't see them (due to display optimisation). This can lead to empty node entries and (new) user confusion. I think it would be better to prevent adding nodes by clicking (it should still be possible to add them by entering coordinates) and instead warn the user, that the action was not taken because of the extreme zoom (something like "zoom closer to add nodes").

Attachments (0)

Change History (14)

comment:1 Changed 14 years ago by ulfl

Hmmm, can't reproduce.

If I start with an empty layer, scale 3867km on my machine, I can draw nodes on the screen that appears immediately.

comment:2 Changed 14 years ago by ulfl

Resolution: fixed
Status: newclosed

Yes, the bar is fast, but there don't seem to be a way to change the speed :-(

I've changed the default width of the dialog to 600 pixels (SVN1304), more looks a bit ugly.

BTW: You also could have changed the size yourself in the advance preferences with: progressdialog.size

comment:3 Changed 14 years ago by anonymous

The size is automatically save when changed :-)

comment:4 Changed 14 years ago by dieterdreist

Priority: majorminor
Resolution: fixed
Status: closedreopened
Version: latest

I really don't understand your comments No. 2 + 3.

About the first one: maybe the displayed scale depends on the screen resolution (mine is quite small: 1280x800), but no matter: I never changed any default setting for display-reduction but the nodes are just shown when I zoom in.

The only thing you notice when drawing is the yellow rubberband, but JOSM doesn't seem to add nodes or ways because they are hidden (of course they are created, you can notice this in command-stack or by zooming in).
The thing is that you can't expect from the average user (or at least the unexperienced one) that he is checking command stack.

If you want I can make a screencast to demonstrate.

comment:5 Changed 14 years ago by ulfl

Ooops, comments 2&3 were meant for a different report - please ignore!

Hmmm, I don't know what's wrong here and can't reproduce on my machine. I guess a screencast won't help a lot as I understand what you mean but don't have a good idea how to fix it. Maybe one of the other developers have an idea and will pick this up?

comment:6 Changed 14 years ago by anonymous

See also #2055 which contains his prefs.

comment:7 Changed 14 years ago by anonymous

Resolution: duplicate
Status: reopenedclosed

Duplicate of #2065 I would think.

comment:8 Changed 14 years ago by anonymous

Resolution: duplicate
Status: closedreopened

comment:9 Changed 14 years ago by anonymous

Status: reopenednew

He is right. He uses mappaint.ZoomLevelDisplay=true.

comment:10 Changed 14 years ago by anonymous

Summary: disable draw on large zooms to prevent erratous adding of nodesPrevent changes when zoom level display is used

comment:11 Changed 14 years ago by stoecker

Cc: resort removed
Keywords: 61603647 removed
Priority: criticalmajor
Summary: resortPrevent changes when zoom level display is used

comment:12 Changed 14 years ago by stoecker

Owner: changed from ce to team

comment:13 Changed 13 years ago by plaicy

Keywords: zooming added

comment:14 Changed 13 years ago by stoecker

Resolution: wontfix
Status: newclosed

We no longer start with high zoom for new layers, so this is fixed. On the other hand the basic problems with mappaint.ZoomLevelDisplay=true are still there and wont vanish (that's why it is off by default).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.