Modify

Opened 3 weeks ago

Closed 3 weeks ago

#20505 closed defect (worksforme)

Remot control "select" regression

Reported by: tomas Owned by: team
Priority: normal Milestone:
Component: Core remotecontrol Version:
Keywords: Cc:

Description

Is it just me, or it used to be years ago that select action on load_and_zoom (f.e. load_and_zoom?select=way12345) would DOWNLOAD the specified object and zoom to its extent?

Currently "select" action just tries to select an already downloaded object with a given ID. So if I want to download and check an object X I have to know its geometry, specify a bbox which would cover at least one node of the object and then I can select. Therefore simple action as given below (with a single "select") becomes something like this:

load_and_zoom?top=55.758&bottom=55.757&left=25.464&right=25.467&select=way12345

Remote control in our case is used for QA checks. And new(?) behaviour is inconvenient because of some reasons:

  1. It downloads more than the object required
  2. When creating a clickable error list we need to include not only object type/id, but also a bbox

Thank you

Attachments (0)

Change History (3)

comment:1 Changed 3 weeks ago by GerdP

I'm not an expert but I think you need load_object, not load_and_zoom. The latter requires the bounding box.

comment:2 Changed 3 weeks ago by tomas

Thank you, you're right, this one does the trick:
load_object?objects=w12345

I've missed the main remote control documentation page: https://josm.openstreetmap.de/wiki/Help/RemoteControlCommands#load_object

comment:3 Changed 3 weeks ago by tomas

Resolution: worksforme
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.