Modify

Opened 3 months ago

Closed 3 months ago

#20420 closed defect (duplicate)

Crash when 'File > Download Along...' selected

Reported by: letsridebikes (OSM username) Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Do not download any OSM data
  2. Open a .gpx track
  3. Click 'File > Download Along...'

What is the expected result?

should provide dialogue to download along GPX route surveyed

What happens instead?

"An unexpected exception occurred. This is always a coding error."

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-12-28 22:03:23 +0100 (Mon, 28 Dec 2020)
Build-Date:2020-12-29 02:30:53
Revision:17428
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17428 en_GB) Windows 7 64-Bit
OS Build number: Windows 7 Professional (7601)
Memory Usage: 887 MB / 1820 MB (376 MB allocated, but free)
Java version: 1.8.0_281-b09, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920×1080 (scaling 1.00×1.00)
Maximum Screen Size: 1920×1080
Best cursor sizes: 16×16→32×32, 32×32→32×32

Plugins:
+ BuildingGeneralization (23)
+ CADTools (1008)
+ ImproveWay (29)
+ PicLayer (2a9aa7a)
+ alignways (35640)
+ apache-commons (35524)
+ apache-http (35589)
+ changeset-viewer (25)
+ continuosDownload (91)
+ editgpx (35562)
+ imagery_offset_db (35640)
+ jna (35662)
+ reverter (35688)
+ terracer (35640)
+ turnrestrictions (35640)
+ undelete (35640)
+ utilsplugin2 (35682)

Last errors/warnings:
- 00006.817 W: Failed to persist preferences to '<josm.pref>\preferences.xml': java.nio.file.AccessDeniedException: <josm.pref>\preferences.xml_backup
- 00006.819 W: Failed to persist preferences to '<josm.pref>\preferences.xml': java.nio.file.AccessDeniedException: <josm.pref>\preferences.xml_backup
- 00009.694 W: Failed to persist preferences to '<josm.pref>\preferences.xml': java.nio.file.AccessDeniedException: <josm.pref>\preferences.xml -> <josm.pref>\preferences.xml_backup
- 00009.701 W: Failed to persist preferences to '<josm.pref>\preferences.xml': java.nio.file.AccessDeniedException: <josm.pref>\preferences.xml -> <josm.pref>\preferences.xml_backup
- 00040.131 E: Handled by bug report queue: java.lang.NullPointerException



=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
java.lang.NullPointerException
	at org.openstreetmap.josm.actions.DownloadAlongWayAction.createTask(DownloadAlongWayAction.java:45)
	at org.openstreetmap.josm.actions.DownloadAlongAction.actionPerformed(DownloadAlongAction.java:307)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.AbstractButton.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (1)

comment:1 Changed 3 months ago by GerdP

Resolution: duplicate
Status: newclosed

Closed as duplicate of #20311.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.