Modify

Opened 7 weeks ago

Closed 7 weeks ago

Last modified 7 weeks ago

#20367 closed defect (duplicate)

`area:highway` is not detected as being an area, causing the validator to be wrong.

Reported by: oliversimmo@… Owned by: team
Priority: normal Milestone:
Component: Core validator Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Create a way with area:highway=*.
  2. Create a way with landuse=*.
  3. Ensure the ways are at least 4 nodes (below 4 will not get detected as an error).
  4. Run the validator.

What is the expected result?

Nothing.
JOSM will not complain, detecting that area:highway=* means it is an area, which are allowed to share segments.

What happens instead?

JOSM complains that "Ways share segment with area" between the landuse and area:highway.
I assume this is because JOSM dosen't detect area:highway and thinks it is a way and not an area.

Example

Attached is an example of data that will cause the issue.
https://i.ibb.co/6JBPBMz/image.png

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-11-21 14:56:29 +0100 (Sat, 21 Nov 2020)
Build-Date:2020-11-22 02:30:52
Revision:17329
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17329 en_GB) Windows 10 64-Bit
OS Build number: Windows 10 Home 2009 (19042)
Memory Usage: 388 MB / 989 MB (85 MB allocated, but free)
Java version: 1.8.0_261-b12, Oracle Corporation, Java HotSpot(TM) Client VM
Look and Feel: com.formdev.flatlaf.FlatDarculaLaf
Screen: \Display0 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32
Dataset consistency test: No problems found

Last errors/warnings:
- 00011.943 W: Failed to delete outdated plugin '<josm.pref>\plugins\flatlaf.jar'.
- 00011.944 W: Failed to install already downloaded plugin 'flatlaf'. Skipping installation. JOSM is still going to load the old plugin version.
- 12172.035 W: org.openstreetmap.josm.data.osm.search.SearchParseError: Unexpected token: <equals>

Attachments (0)

Change History (4)

comment:1 Changed 7 weeks ago by GoodClover

Sorry I mistyped in step 3.
Should say:

  1. Ensure the ways share are at least 4 nodes (below 4 will not get detected as an error).
Last edited 7 weeks ago by GoodClover (previous) (diff)

comment:2 Changed 7 weeks ago by GerdP

I think this doesn't happen with tested version r17428, please update.

comment:3 Changed 7 weeks ago by GerdP

Resolution: invalid
Status: newclosed

Was fixed with r17350

comment:4 Changed 7 weeks ago by Don-vip

Resolution: invalidduplicate

Marked as duplicate of #20031.
Please update to current version of JOSM!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.