Modify

Opened 3 months ago

Closed 5 weeks ago

Last modified 3 weeks ago

#20031 closed defect (fixed)

area:highway validation produces false positive "Overlapping ways"

Reported by: Allroads Owned by: team
Priority: major Milestone: 20.12
Component: Core validator Version: tested
Keywords: polygon overlap area area:highway Cc:

Description (last modified by Allroads)

Two connected polygons area:highway give a validation warning. Which is not correct.


Attachments (1)

areahighwayconnected.JPG (88.5 KB) - added by Allroads 3 months ago.

Download all attachments as: .zip

Change History (10)

Changed 3 months ago by Allroads

Attachment: areahighwayconnected.JPG added

comment:1 Changed 3 months ago by Allroads

Description: modified (diff)

comment:2 Changed 3 months ago by skyper

+1
Can also be multipolygons.

How about supporting area:highway in general? E.g. own preset, include in internal style and update validator

comment:3 Changed 3 months ago by skyper

See also #19465.

comment:4 Changed 3 months ago by skyper

Keywords: overlap area area:highway added

comment:5 in reply to:  2 Changed 2 months ago by skyper

Replying to skyper:

How about supporting area:highway in general? E.g. own preset, include in internal style and update validator

See #20102 for the preset and style part.

comment:6 Changed 5 weeks ago by GerdP

Summary: area:highway validation warning, not correct.area:highway validation produces false positive "Overlapping ways"

comment:7 Changed 5 weeks ago by GerdP

Resolution: fixed
Status: newclosed

In 17425/josm:

fix #20031: area:highway validation produces false positive "Overlapping ways"

  • add area:highway to the list of tags that describe an area so that it is ignored by the OverlappingWays test

comment:8 Changed 5 weeks ago by GerdP

Milestone: 20.12

comment:9 Changed 3 weeks ago by Don-vip

Ticket #20367 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.