Modify

Opened 3 weeks ago

Closed 3 weeks ago

#20360 closed enhancement (fixed)

[Patch] Splash screen: Automatically focus beginning of line

Reported by: skyper Owned by: team
Priority: minor Milestone: 21.01
Component: Core Version:
Keywords: template_report startup splash screen Cc: DevCharly

Description (last modified by skyper)

Thanks for your improvements so far.

What steps will reproduce the problem?

  1. Start JOSM with some plugins installed
  2. Watch the splash screen info and see some lines with indent (listings)
  3. Watch the next lines and notice the vertical scrollbar at the bottom

What is the expected result?

The beginning of the lines get the focus in order to see the first letters of the lines

What happens instead?

The focus is not properly adjusted and I have to scroll to the left to see the beginning of the next lines.

Please provide any additional information below. Attach a screenshot if possible.

Noticed this for some time now but never reported it. Sorry.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2021-01-06 16:47:43 +0100 (Wed, 06 Jan 2021)
Revision:17446
Build-Date:2021-01-07 02:30:51
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (17446 en) Linux Debian GNU/Linux 10 (buster)
Java version: 11.0.9.1+1-post-Debian-1deb10u2, Debian, OpenJDK 64-Bit Server VM
Look and Feel: com.formdev.flatlaf.FlatDarkLaf

Plugins:
+ flatlaf (35679)

Attachments (2)

josm_20360_splash_screen.png (58.8 KB) - added by skyper 3 weeks ago.
screenshot
JOSM-splash-wrap-fix.diff (1.7 KB) - added by DevCharly 3 weeks ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 3 weeks ago by DevCharly

With "startup info", do you mean the splash screen temporary shown at startup?

On my machine the splash screen is shown for only 1-2 seconds
and I can not focus it or scroll it be gone...

Can you post a screenshot?

comment:2 Changed 3 weeks ago by skyper

Description: modified (diff)
Keywords: startup splash screen added
Summary: Startup Info: Automatically focus beginning of lineSplash screen: Automatically focus beginning of line

Sorry, yes, the splash screen. Strange, right now, I cannot reproduce it, e.g. no screenshot possible. Have to be ready to take screenshots once I notice it, again.

It has something to do with external sources like plugins, presets, styles and rules, so maybe an automatically update of plugins on startup is needed.

Changed 3 weeks ago by skyper

screenshot

comment:3 Changed 3 weeks ago by skyper

screenshot Here is a screenshot. The plugin listing are the cached .jar files not the active plugins and indeed, this is the first start after a JOSM update which triggers an automatically plugin update with my settings.

Last edited 3 weeks ago by skyper (previous) (diff)

comment:4 Changed 3 weeks ago by DevCharly

The problem is probably that there is a longer string without spaces
(e.g. a path) somewhere in in the output, which can not word-wrapped.

This is not FlatLaf related.
Occurs with all Lafs.

BTW the bar at the bottom is not a scrollbar.
It is a progressbar ;)

I'll provide a patch...

Changed 3 weeks ago by DevCharly

Attachment: JOSM-splash-wrap-fix.diff added

comment:5 in reply to:  4 Changed 3 weeks ago by skyper

Replying to DevCharly:

This is not FlatLaf related.
Occurs with all Lafs.

Strange, I have never noticed it wit Metal

BTW the bar at the bottom is not a scrollbar.
It is a progressbar ;)

Surprisingly, it is possible to scroll with it but maybe the last line has the focus.

comment:6 Changed 3 weeks ago by skyper

Component: Plugin flatlafCore
Owner: changed from simon04 to team
Summary: Splash screen: Automatically focus beginning of line[Patch] Splash screen: Automatically focus beginning of line

comment:7 Changed 3 weeks ago by Don-vip

Milestone: 21.01

comment:8 Changed 3 weeks ago by Don-vip

Resolution: fixed
Status: newclosed

In 17449/josm:

fix #20360 - fix splash screen scrolling (patch by DevCharly)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.