Modify

Opened 2 months ago

Closed 2 months ago

#20265 closed defect (duplicate)

Josm don't start

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core imagery Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-11-21 14:56:29 +0100 (Sat, 21 Nov 2020)
Build-Date:2020-11-22 02:30:52
Revision:17329
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17329 de) Linux Mint 18 Sarah
Memory Usage: 731 MB / 1748 MB (162 MB allocated, but free)
Java version: 1.8.0_275-8u275-b01-0ubuntu1~16.04-b01, Private Build, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 1600x900 (scaling 1.0x1.0)
Maximum Screen Size: 1600x900
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
Desktop environment: X-Cinnamon
Java package: openjdk-8-jre:amd64-8u275-b01-0ubuntu1~16.04
Environment variable LANG: de_DE.UTF-8
fonts-noto: fonts-noto:all-20160116-1

Plugins:
+ HouseNumberTaggingTool
+ Mapillary
+ OpeningHoursEditor
+ apache-commons
+ apache-http
+ buildings_tools
+ javafx-unixoid (35458)
+ jaxb (35543)
+ jna
+ jogl
+ log4j (35458)
+ measurement
+ terracer
+ turnrestrictions

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/StolpersteineLight&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Stolpersteine&zip=1
+ ${HOME}/Dokumente/xmas.xml

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Enhanced_Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_buildings&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/TigerReviewedNo&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Modified&zip=1

Last errors/warnings:
- 00025,935 W:  XMAS: Could not get presets icon xmastree.png
- 00025,936 E: Fehler beim Laden des Bildes 'xmastree.png'
- 00025,937 W:  Weihnachtsbaum: Could not get presets icon xmastree.png
- 00025,939 E: Fehler beim Laden des Bildes 'xmas_market.png'
- 00025,939 W:  Weihnachtsmarkt: Could not get presets icon xmas_market.png
- 00025,946 E: Fehler beim Laden des Bildes 'xmas_event.png'
- 00025,946 W:  WeihnachtsEvent: Could not get presets icon xmas_event.png
- 00025,948 E: Fehler beim Laden des Bildes 'xmas_pyramid.png'
- 00025,952 W:  Weihnachtspyramide: Could not get presets icon xmas_pyramid.png
- 00026,321 E: Handled by bug report queue: org.openstreetmap.josm.tools.JosmRuntimeException: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: Hintergrundbild WMS hat einen tileMatrixSet-Definition von: EPSG:2180. Ursache: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: Hintergrundbild WMS hat einen tileMatrixSet-Definition von: EPSG:2180. Ursache: java.lang.IllegalArgumentException: Hintergrundbild WMS hat einen tileMatrixSet-Definition von: EPSG:2180


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
org.openstreetmap.josm.tools.JosmRuntimeException: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: Hintergrundbild WMS hat einen tileMatrixSet-Definition von: EPSG:2180
	at org.openstreetmap.josm.spi.lifecycle.Lifecycle.initialize(Lifecycle.java:89)
	at org.openstreetmap.josm.gui.MainApplication.mainJOSM(MainApplication.java:919)
	at org.openstreetmap.josm.gui.MainApplication$3.processArguments(MainApplication.java:277)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:714)
Caused by: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: Hintergrundbild WMS hat einen tileMatrixSet-Definition von: EPSG:2180
	at java.util.concurrent.FutureTask.report(FutureTask.java:122)
	at java.util.concurrent.FutureTask.get(FutureTask.java:192)
	at org.openstreetmap.josm.spi.lifecycle.Lifecycle.initialize(Lifecycle.java:78)
	... 3 more
Caused by: java.lang.IllegalArgumentException: Hintergrundbild WMS hat einen tileMatrixSet-Definition von: EPSG:2180
	at org.openstreetmap.josm.data.imagery.DefaultLayer.<init>(DefaultLayer.java:37)
	at org.openstreetmap.josm.io.imagery.ImageryReader$Parser.startElement(ImageryReader.java:306)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.startElement(AbstractSAXParser.java:509)
	at com.sun.org.apache.xerces.internal.parsers.AbstractXMLDocumentParser.emptyElement(AbstractXMLDocumentParser.java:182)
	at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.scanStartElement(XMLNSDocumentScannerImpl.java:351)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(XMLDocumentFragmentScannerImpl.java:2784)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:602)
	at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(XMLNSDocumentScannerImpl.java:112)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:505)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:842)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:771)
	at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:141)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1213)
	at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:643)
	at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl.parse(SAXParserImpl.java:327)
	at org.openstreetmap.josm.tools.XmlUtils.parseSafeSAX(XmlUtils.java:123)
	at org.openstreetmap.josm.io.imagery.ImageryReader.parse(ImageryReader.java:103)
	at org.openstreetmap.josm.data.imagery.ImageryLayerInfo$DefaultEntryLoader.loadSource(ImageryLayerInfo.java:168)
	at org.openstreetmap.josm.data.imagery.ImageryLayerInfo$DefaultEntryLoader.realRun(ImageryLayerInfo.java:156)
	at org.openstreetmap.josm.data.imagery.ImageryLayerInfo.loadDefaults(ImageryLayerInfo.java:119)
	at org.openstreetmap.josm.data.imagery.ImageryLayerInfo.load(ImageryLayerInfo.java:101)
	at org.openstreetmap.josm.gui.preferences.imagery.ImageryPreference.initialize(ImageryPreference.java:328)
	at org.openstreetmap.josm.spi.lifecycle.InitializationTask.call(InitializationTask.java:33)
	at org.openstreetmap.josm.spi.lifecycle.InitializationTask.call(InitializationTask.java:11)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at java.lang.Thread.run(Thread.java:748)

Attachments (0)

Change History (1)

comment:1 Changed 2 months ago by skyper

Component: CoreCore imagery
Resolution: duplicate
Status: newclosed

Closed as duplicate of #20262.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.