Modify

Opened 6 weeks ago

Closed 6 weeks ago

Last modified 6 weeks ago

#20262 closed defect (fixed)

IAE: WMS imagery has tileMatrixSet set to : EPSG:2180

Reported by: cquest@… Owned by: Don-vip
Priority: critical Milestone: 20.12
Component: Core imagery Version: latest
Keywords: template_report wms projection tile matrix wmts Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-12-14 18:34:04 +0100 (Mon, 14 Dec 2020)
Revision:17410
Build-Date:2020-12-15 02:30:50
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (17410 fr) Linux Ubuntu 20.04.1 LTS
Memory Usage: 2192 MB / 24160 MB (1494 MB allocated, but free)
Java version: 11.0.9.1+1-Ubuntu-0ubuntu1.20.04, Ubuntu, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.nimbus.NimbusLookAndFeel
Screen: :0.0 2560×1600 (scaling 1,00×1,00)
Maximum Screen Size: 2560×1600
Best cursor sizes: 16×16→16×16, 32×32→32×32
Desktop environment: Unity:Unity7:ubuntu
Java package: openjdk-11-jre:amd64-11.0.9.1+1-0ubuntu1~20.04
Java ATK Wrapper package: libatk-wrapper-java:all-0.37.1-1
Environment variable LANG: fr_FR.UTF-8
fonts-noto: fonts-noto:-

Plugins:
+ BuildingGeneralization
+ FixAddresses
+ ImportImagePlugin
+ ImproveWay
+ OpeningHoursEditor
+ PicLayer
+ PolygonCutOut
+ RoadSigns
+ SimplifyArea
+ apache-commons
+ apache-http
+ areaselector
+ austriaaddresshelper
+ auto_tools
+ buildings_tools
+ cadastre-fr
+ conflation
+ ejml
+ geotools
+ highwayNameModification
+ http2 (35427)
+ imagery-xml-bounds
+ imagery_offset_db
+ importvec
+ jaxb (35543)
+ jna
+ jts
+ log4j (35458)
+ mbtiles
+ measurement
+ merge-overlap
+ microdata_scraping
+ opendata
+ openqa
+ openvisible
+ rasterfilters
+ reltoolbox
+ reverter
+ tageditor
+ todo
+ turnlanes
+ turnrestrictions
+ undelete
+ utilsplugin2
+ wikipedia

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1

Map paint styles:
- https://github.com/simon04/coloured-addresses.mapcss/raw/master/dist/coloured-addresses.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&style&zip=1
- https://raw.githubusercontent.com/species/josm-preset-wheelchair/master/sidewalks_kerbs.mapcss

Last errors/warnings:
- 00011,504 E: Handled by bug report queue: org.openstreetmap.josm.tools.JosmRuntimeException: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: l'imagerie WMS a tileMatrixSet défini à : EPSG:2180. Cause : java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: l'imagerie WMS a tileMatrixSet défini à : EPSG:2180. Cause : java.lang.IllegalArgumentException: l'imagerie WMS a tileMatrixSet défini à : EPSG:2180



=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
org.openstreetmap.josm.tools.JosmRuntimeException: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: l'imagerie WMS a tileMatrixSet défini à : EPSG:2180
	at org.openstreetmap.josm.spi.lifecycle.Lifecycle.initialize(Lifecycle.java:89)
	at org.openstreetmap.josm.gui.MainApplication.mainJOSM(MainApplication.java:919)
	at org.openstreetmap.josm.gui.MainApplication$3.processArguments(MainApplication.java:277)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:714)
Caused by: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: l'imagerie WMS a tileMatrixSet défini à : EPSG:2180
	at java.base/java.util.concurrent.FutureTask.report(FutureTask.java:122)
	at java.base/java.util.concurrent.FutureTask.get(FutureTask.java:191)
	at org.openstreetmap.josm.spi.lifecycle.Lifecycle.initialize(Lifecycle.java:78)
	... 3 more
Caused by: java.lang.IllegalArgumentException: l'imagerie WMS a tileMatrixSet défini à : EPSG:2180
	at org.openstreetmap.josm.data.imagery.DefaultLayer.<init>(DefaultLayer.java:37)
	at org.openstreetmap.josm.io.imagery.ImageryReader$Parser.startElement(ImageryReader.java:306)
	at java.xml/com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.startElement(AbstractSAXParser.java:510)
	at java.xml/com.sun.org.apache.xerces.internal.parsers.AbstractXMLDocumentParser.emptyElement(AbstractXMLDocumentParser.java:183)
	at java.xml/com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.scanStartElement(XMLNSDocumentScannerImpl.java:351)
	at java.xml/com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(XMLDocumentFragmentScannerImpl.java:2710)
	at java.xml/com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:605)
	at java.xml/com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(XMLNSDocumentScannerImpl.java:112)
	at java.xml/com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:534)
	at java.xml/com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:888)
	at java.xml/com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:824)
	at java.xml/com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:141)
	at java.xml/com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1216)
	at java.xml/com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:635)
	at java.xml/com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl.parse(SAXParserImpl.java:324)
	at org.openstreetmap.josm.tools.XmlUtils.parseSafeSAX(XmlUtils.java:123)
	at org.openstreetmap.josm.io.imagery.ImageryReader.parse(ImageryReader.java:103)
	at org.openstreetmap.josm.data.imagery.ImageryLayerInfo$DefaultEntryLoader.loadSource(ImageryLayerInfo.java:168)
	at org.openstreetmap.josm.data.imagery.ImageryLayerInfo$DefaultEntryLoader.realRun(ImageryLayerInfo.java:156)
	at org.openstreetmap.josm.data.imagery.ImageryLayerInfo.loadDefaults(ImageryLayerInfo.java:119)
	at org.openstreetmap.josm.data.imagery.ImageryLayerInfo.load(ImageryLayerInfo.java:101)
	at org.openstreetmap.josm.gui.preferences.imagery.ImageryPreference.initialize(ImageryPreference.java:328)
	at org.openstreetmap.josm.spi.lifecycle.InitializationTask.call(InitializationTask.java:33)
	at org.openstreetmap.josm.spi.lifecycle.InitializationTask.call(InitializationTask.java:11)
	at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
	at java.base/java.lang.Thread.run(Thread.java:834)

Attachments (0)

Change History (19)

comment:1 Changed 6 weeks ago by Don-vip

Component: CoreCore imagery
Keywords: poland wms projection tile matrix added
Summary: Bug at startup... same with latest/testedIAE: WMS imagery has tileMatrixSet set to : EPSG:2180

comment:2 Changed 6 weeks ago by skyper

Ticket #20261 has been marked as a duplicate of this ticket.

comment:3 Changed 6 weeks ago by skyper

Ticket #20263 has been marked as a duplicate of this ticket.

comment:4 Changed 6 weeks ago by skyper

Ticket #20265 has been marked as a duplicate of this ticket.

comment:5 Changed 6 weeks ago by skyper

Ticket #20266 has been marked as a duplicate of this ticket.

comment:6 Changed 6 weeks ago by skyper

Keywords: EPSG:2180 added
Priority: normalcritical

See #20264 for similar issue.

Will removing EPSG:2180 from available projections help or is it a bad hack?

comment:7 Changed 6 weeks ago by skyper

Ticket #20267 has been marked as a duplicate of this ticket.

comment:8 Changed 6 weeks ago by GerdP

comment:9 in reply to:  8 Changed 6 weeks ago by skyper

Replying to GerdP:

Could this change be related?
https://josm.openstreetmap.de/wiki/Maps/Poland?action=diff&version=184

Think this was the fix for this ticket and #20264.

comment:10 Changed 6 weeks ago by anonymous

may be but this did not fix it

comment:11 Changed 6 weeks ago by GerdP

I assume users have to manually delete the cached file mirror_https___josm.openstreetmap.de_maps

comment:12 Changed 6 weeks ago by skyper

If you are able to get to the imagery preferences an update of the default entries should work. Otherwise the cached file needs to be deleted.

comment:13 in reply to:  12 Changed 6 weeks ago by anonymous

Replying to skyper:

If you are able to get to the imagery preferences an update of the default entries should work. Otherwise the cached file needs to be deleted.

This allows to run JOSM but there is still a problem with Imagery sync process

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-11-21 14:56:29 +0100 (Sat, 21 Nov 2020)
Build-Date:2020-11-22 02:30:52
Revision:17329
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17329 pl) Windows 10 64-Bit
OS Build number: Windows 10 Education 2009 (19042)
Memory Usage: 802 MB / 1820 MB (186 MB allocated, but free)
Java version: 1.8.0_271-b09, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920x1080 (scaling 1.0x1.0), \Display1 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32
VM arguments: [-Djava.security.manager, -Djava.security.policy=file:<java.home>\lib\security\javaws.policy, -DtrustProxy=true, -Djnlpx.home=<java.home>\bin, -Djnlpx.origFilenameArg=%UserProfile%\Downloads\josm.jnlp, -Djnlpx.remove=false, -Djava.util.Arrays.useLegacyMergeSort=true, -Djnlpx.heapsize=NULL,2048m, -Djnlpx.splashport=61386, -Djnlpx.jvm=<java.home>\bin\javaw.exe]

Plugins:
+ PicLayer (2a9aa7a)
+ indoorhelper (eca65b2)

Map paint styles:
- <josm.pref>\styles\sit.mapcss

Last errors/warnings:
- 00025,060 E: Handled by bug report queue: java.lang.IllegalArgumentException: Obrazy WMS mają zdefiniowane tileMatrixSet do: EPSG:2180
- 00136,547 E: Handled by bug report queue: java.lang.IllegalArgumentException: Obrazy WMS mają zdefiniowane tileMatrixSet do: EPSG:2180


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-2 (60) of javawsApplicationThreadGroup
java.lang.IllegalArgumentException: Obrazy WMS mają zdefiniowane tileMatrixSet do: EPSG:2180
	at org.openstreetmap.josm.data.imagery.DefaultLayer.<init>(DefaultLayer.java:37)
	at org.openstreetmap.josm.io.imagery.ImageryReader$Parser.startElement(ImageryReader.java:306)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.startElement(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.AbstractXMLDocumentParser.emptyElement(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.scanStartElement(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl.parse(Unknown Source)
	at org.openstreetmap.josm.tools.XmlUtils.parseSafeSAX(XmlUtils.java:123)
	at org.openstreetmap.josm.io.imagery.ImageryReader.parse(ImageryReader.java:103)
	at org.openstreetmap.josm.data.imagery.ImageryLayerInfo$DefaultEntryLoader.loadSource(ImageryLayerInfo.java:168)
	at org.openstreetmap.josm.data.imagery.ImageryLayerInfo$DefaultEntryLoader.realRun(ImageryLayerInfo.java:156)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:94)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:142)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

comment:14 Changed 6 weeks ago by Don-vip

Ticket #20264 has been marked as a duplicate of this ticket.

comment:15 Changed 6 weeks ago by Don-vip

Milestone: 20.12
Owner: changed from team to Don-vip
Status: newassigned

comment:16 Changed 6 weeks ago by Don-vip

Keywords: wmts added; poland EPSG:2180 removed

comment:17 Changed 6 weeks ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 17417/josm:

fix #20262 - make ImageryReader robust to the fact imagery layers sometimes can't be created successfuly

comment:18 Changed 6 weeks ago by anonymous

could we have someone fix the broken imagery layers behind this problem?

comment:19 in reply to:  18 Changed 6 weeks ago by Klumbumbus

Replying to anonym:

could we have someone fix the broken imagery layers behind this problem?

This should already be done. The bad entries were https://josm.openstreetmap.de/wiki/Maps/Poland?action=diff&version=181 and https://josm.openstreetmap.de/wiki/Maps/Poland?action=diff&version=183 which added a WMS with tile-matrix-set which is for WMTS only. This was removed in https://josm.openstreetmap.de/wiki/Maps/Poland?action=diff&version=184.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.