Modify

Opened 3 months ago

Closed 3 months ago

#20175 closed defect (duplicate)

Parallel tool gives length of resulting way instead of offset

Reported by: denelson83@… Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Select the "parallel" tool.
  2. Click and drag on a way.

What is the expected result?

The length value in the status bar should give the length of the offset from the original way.

What happens instead?

The length value in the status bar is the length of the resulting way.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-10-03 13:42:38 +0200 (Sat, 03 Oct 2020)
Build-Date:2020-10-04 01:30:47
Revision:17084
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17084 en) Windows 10 64-Bit
OS Build number: Windows 10 Home 1909 (18363)
Memory Usage: 907 MB / 1820 MB (585 MB allocated, but free)
Java version: 1.8.0_261-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32
Dataset consistency test: No problems found

Plugins:
+ Create_grid_of_ways (35640)
+ ImproveWay (29)
+ alignways (35640)
+ apache-commons (35524)
+ canvec_helper (35458)
+ centernode (v1.0.4)
+ ejml (35458)
+ geotools (35458)
+ gridify (1588746833)
+ jaxb (35543)
+ jts (35458)
+ measurement (35640)
+ opendata (35640)
+ splinex (35562)
+ utilsplugin2 (35640)

Last errors/warnings:
- 204923.935 W: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.SocketTimeoutException: connect timed out
- 466525.817 W: java.net.SocketTimeoutException: connect timed out
- 466525.818 E: java.net.SocketTimeoutException: connect timed out
- 647269.723 W: java.net.UnknownHostException: api.openstreetmap.org
- 647269.723 W: Already here java.net.SocketTimeoutException: connect timed out
- 647269.738 E: java.net.UnknownHostException: api.openstreetmap.org
- 647269.754 W: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.UnknownHostException: api.openstreetmap.org
- 954804.530 E: Communication with OSM server failed - null
- 1177659.237 W: JOSM expected to find primitive [way -102815] in dataset but it is not there. Please report this at https://josm.openstreetmap.de. This is not a critical error, it should be safe to continue in your work.
- 1177659.468 E: java.lang.Exception

Attachments (0)

Change History (1)

comment:1 Changed 3 months ago by GerdP

Resolution: duplicate
Status: newclosed

Closed as duplicate of #19887.
Please update JOSM

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.