Modify

Opened 7 weeks ago

Closed 7 weeks ago

Last modified 7 weeks ago

#20165 closed defect (fixed)

Changset manager: Discussion tab: Problem with sorting by date

Reported by: skyper Owned by: team
Priority: normal Milestone: 20.12
Component: Core Version: latest
Keywords: template_report changeset manger discussion sort date Cc:

Description

What steps will reproduce the problem?

  1. Open changeset #85329869 in changeset manager
  2. Open Discussion tab in lower half
  3. Sort by date twice

What is the expected result?

The same order as before sorting

What happens instead?

The order is messed up and the first comment is not in first place.

Please provide any additional information below. Attach a screenshot if possible.

Looks like the time is upside-down for each day.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-11-26 22:24:27 +0100 (Thu, 26 Nov 2020)
Revision:17364
Build-Date:2020-11-27 02:30:53
URL:https://josm.openstreetmap.de/svn/trunk

Attachments (0)

Change History (2)

comment:1 Changed 7 weeks ago by GerdP

Resolution: fixed
Status: newclosed

In 17370/josm:

fix #20165: Changset manager: Discussion tab: Problem with sorting by date

  • implement special sorter for date

Cannot use automatically created row sorter because it uses Object.toString() for sorting and the format returned by Date.toString() (e.g. "Sat May 30 08:54:31 CEST 2020") is not usable for sorting.

comment:2 Changed 7 weeks ago by GerdP

Milestone: 20.12

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.