Modify

Opened 7 weeks ago

Closed 7 weeks ago

Last modified 7 weeks ago

#20163 closed defect (duplicate)

Split way corrupts relation when splitting via way

Reported by: GerdP Owned by: GerdP
Priority: normal Milestone: 20.12
Component: Core Version: tested
Keywords: template_report Cc:

Description (last modified by GerdP)

What steps will reproduce the problem?

  1. Load attached file
  2. Add node in via way (w757606841)
  3. split at this node

What is the expected result?

Turn restriction r10452821 contains both parts of the way or at least a warning to check the relation

What happens instead?

Turn restriction r10452821 contains only one part and is broken.

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-11-21 14:56:29 +0100 (Sat, 21 Nov 2020)
Build-Date:2020-11-22 02:30:52
Revision:17329
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17329 en) Windows 10 64-Bit
OS Build number: Windows 10 Home 2004 (19041)
Memory Usage: 964 MB / 3641 MB (845 MB allocated, but free)
Java version: 1.8.0_221-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32
VM arguments: [-XX:StartFlightRecording=name=MyRecording2,settings=d:\dbg\gerd.jfc, -XX:FlightRecorderOptions=defaultrecording=true,dumponexit=true,dumponexitpath=e:\ld\perf_20201127_164151.jfr]
Dataset consistency test: No problems found

Plugins:
+ buildings_tools (35640)
+ o5m (35640)
+ pbf
+ poly (35640)
+ reltoolbox (35640)
+ reverter (35640)
+ undelete (35640)
+ utilsplugin2 (35640)

Validator rules:
+ c:\josm\core\resources\data\validator\geometry.mapcss

Last errors/warnings:
- 00008.079 W: Warning - <html>Plugin pbf requires JOSM version 17334. The current JOSM version is 17329.<br>You have to update JOSM in order to use this plugin.</html>

Attachments (2)

data-20163.osm (23.5 KB) - added by GerdP 7 weeks ago.
20163.patch (1.7 KB) - added by GerdP 7 weeks ago.
fix and unit test, seems to fix 10808 as well

Download all attachments as: .zip

Change History (9)

Changed 7 weeks ago by GerdP

Attachment: data-20163.osm added

comment:1 Changed 7 weeks ago by GerdP

Description: modified (diff)
Owner: changed from team to GerdP
Status: newassigned

comment:2 Changed 7 weeks ago by skyper

Duplicate of #10808.

comment:3 Changed 7 weeks ago by GerdP

Not really. In my case all data is downloaded. Will look at it anyway.

Changed 7 weeks ago by GerdP

Attachment: 20163.patch added

fix and unit test, seems to fix 10808 as well

comment:4 Changed 7 weeks ago by GerdP

Resolution: fixed
Status: assignedclosed

In 17375/josm:

fix #20163: Split way corrupts relation when splitting via way

  • if via way in turn restriction is split we have to insert new member

comment:5 Changed 7 weeks ago by GerdP

Milestone: 20.12

comment:6 Changed 7 weeks ago by skyper

Yes, should fix #10808, as unlike other restriction relations only the via way needs to be downloaded in order to know what to do (adding all fresh created ways to the relation).

comment:7 Changed 7 weeks ago by GerdP

Resolution: fixedduplicate

Marked as duplicate of #10808.
Yes, sorry, the part "relation isn't fully downloaded" is not relevant here.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain GerdP.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.