Modify

Opened 9 days ago

Closed 8 days ago

Last modified 8 days ago

#20131 closed defect (fixed)

load_and_zoom returns OK even if area is too big

Reported by: bagage Owned by: Don-vip
Priority: normal Milestone: 20.12
Component: Core remotecontrol Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

Try to download a big area via remotecontrol: http://127.0.0.1:8111/load_and_zoom?new_layer=true&left=-0.612868037647615&right=-0.428394670196241&bottom=48.4686131382385&top=48.5853619853333

What is the expected result?

Since the area is too big, the remotecontrol should return a 400 bad request or something else.

What happens instead?

200 OK is returned.

The problem is: there is no way to know if that succeeded or not (alternative workaround would be to have a layers API to list existing ones).

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-10-03 13:42:38 +0200 (Sat, 03 Oct 2020)
Build-Date:2020-10-04 01:30:47
Revision:17084
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17084 fr) Linux Debian GNU/Linux bullseye/sid
Memory Usage: 791 MB / 4423 MB (292 MB allocated, but free)
Java version: 1.8.0_272-8u272-b10-1-b10, Debian, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
Desktop environment: GNOME
Java package: openjdk-8-jre:amd64-8u272-b10-1
Java ATK Wrapper package: libatk-wrapper-java:all-0.38.0-1
libcommons-compress-java: libcommons-compress-java:-
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:all-20201109-1
liboauth-signpost-java: liboauth-signpost-java:-
Dataset consistency test: No problems found

Plugins:
+ AddrInterpolation (35640)
+ HouseNumberTaggingTool (35640)
+ OpeningHoursEditor (35640)
+ PicLayer (2a9aa7a)
+ PolygonCutOut (v0.7)
+ apache-commons (35524)
+ buildings_tools (35640)
+ cadastre-fr (35640)
+ conflation (0.6.6)
+ ejml (35458)
+ geotools (35458)
+ jts (35458)
+ measurement (35640)
+ poly (35640)
+ reverter (35640)
+ scripting (30798)
+ terracer (35640)
+ todo (30306)
+ utilsplugin2 (35640)
+ wikipedia (1.1.4)

Last errors/warnings:
- 00135,730 E: Requête incorrecte - <html>Le serveur 'api.openstreetmap.org' a signalé une requête erronée.<br><br>La zone que vous voulez télécharger est trop grande ou votre requête est trop grosse. <br>Veuillez sélectionner une zone plus petite ou utiliser un fichier d’export fourni par la communauté OSM.</html>
- 50395,920 E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<You requested too many nodes (limit is 50000). Either request a smaller area, or use planet.osm>
- 50395,936 E: Requête incorrecte - <html>Le serveur 'api.openstreetmap.org' a signalé une requête erronée.<br><br>La zone que vous voulez télécharger est trop grande ou votre requête est trop grosse. <br>Veuillez sélectionner une zone plus petite ou utiliser un fichier d’export fourni par la communauté OSM.</html>
- 50412,047 E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<You requested too many nodes (limit is 50000). Either request a smaller area, or use planet.osm>
- 50412,054 E: Requête incorrecte - <html>Le serveur 'api.openstreetmap.org' a signalé une requête erronée.<br><br>La zone que vous voulez télécharger est trop grande ou votre requête est trop grosse. <br>Veuillez sélectionner une zone plus petite ou utiliser un fichier d’export fourni par la communauté OSM.</html>
- 50593,425 W: 'load_and_zoom' remote control request must have 'bottom' parameter
- 50593,425 W: 'load_and_zoom' remote control request must have 'top' parameter
- 50593,425 W: 'load_and_zoom' remote control request must have 'right' parameter
- 50683,971 E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<You requested too many nodes (limit is 50000). Either request a smaller area, or use planet.osm>
- 50683,984 E: Requête incorrecte - <html>Le serveur 'api.openstreetmap.org' a signalé une requête erronée.<br><br>La zone que vous voulez télécharger est trop grande ou votre requête est trop grosse. <br>Veuillez sélectionner une zone plus petite ou utiliser un fichier d’export fourni par la communauté OSM.</html>

Attachments (0)

Change History (7)

comment:1 Changed 9 days ago by Don-vip

Owner: changed from team to Don-vip
Status: newassigned
Type: enhancementdefect

comment:2 Changed 9 days ago by bagage

Side issue: if you try to load an object with load_object with an invalid type (eg 12345 instead of n12345 or r12345), it says OK instead of bad request too:

OK: http://127.0.0.1:8111/load_object?new_layer=true&objects=r76306

OK, but should actually fail (it does nothing in JOSM but returns OK): http://127.0.0.1:8111/load_object?new_layer=true&objects=r76306

comment:3 Changed 8 days ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 17330/josm:

fix #20131 - remote control: report errors in case of OSM API error (load_and_zoom) or no valid identifier (load_object)

comment:4 Changed 8 days ago by Don-vip

Milestone: 20.12

comment:5 Changed 8 days ago by GerdP

Resolution: fixed
Status: closedreopened

comment:6 Changed 8 days ago by Don-vip

Resolution: fixed
Status: reopenedclosed

In 17332/josm:

fix #20131 - fix unit tests and codestyle violations

comment:7 Changed 8 days ago by GerdP

BTW: I wondered why ant checkstyle-changed ignores the files in scripts/ Probably not intended?

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.