Modify

Opened 4 weeks ago

Closed 4 weeks ago

Last modified 8 days ago

#20009 closed enhancement (fixed)

Build macOS bundles on Java 15, not 16ea

Reported by: Stereo Owned by: team
Priority: normal Milestone: 20.11
Component: Installer MacOS Version:
Keywords: Cc:

Description

The Java 16-ea bundles aren't quite ready for prime time yet, and don't launch reliably; the Java 15 builds work better.

In .github/workflows/ant.yml line 33, please update - java: 15 to - java: 16-ea so that 16-ea gets excluded from the macOS builds.

This will let us link to the 15 builds for the upcoming tested release. Before next month, I'll update the process so that we can have both "stable" Java 15 builds and "unstable" Java 16-ea builds for macOS.

Attachments (0)

Change History (4)

comment:1 Changed 4 weeks ago by Stereo

See also #19937.

Once this is done, I think we can close both?

comment:2 Changed 4 weeks ago by Don-vip

Resolution: fixed
Status: newclosed

In 17287/josm:

fix #20009 - Build macOS bundles on Java 15, not 16-ea (yet)

comment:3 Changed 4 weeks ago by Don-vip

Type: defectenhancement

comment:4 Changed 8 days ago by Don-vip

Milestone: 20.1020.11

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.