Modify

Opened 10 days ago

Closed 10 days ago

Last modified 10 days ago

#19964 closed defect (fixed)

Fatal: failed to locate image '/colorchooser.???'.

Reported by: GerdP Owned by: team
Priority: critical Milestone: 20.10
Component: Core Version: latest
Keywords: template_report regression Cc: simon04

Description (last modified by GerdP)

What steps will reproduce the problem?

  1. ant clean dist
  2. start JOSM
  3. press F12

What is the expected result?

preferences dialog

What happens instead?

bug report

Please provide any additional information below. Attach a screenshot if possible.

Build-Date:2020-10-18 17:14:54
Revision:17236
Is-Local-Build:true

Identification: JOSM/1.5 (17236 SVN en) Windows 10 64-Bit
OS Build number: Windows 10 Home 2004 (19041)
Memory Usage: 798 MB / 1792 MB (613 MB allocated, but free)
Java version: 1.8.0_201-b09, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 48x48, 32x32 -> 48x48

Plugins:
+ apache-commons (35524)
+ buildings_tools (35579)
+ continuosDownload (91)
+ ejml (35313)
+ flatlaf (35572)
+ geotools (35169)
+ jaxb (35092)
+ jts (35122)
+ measurement (35579)
+ o5m (35248)
+ opendata (35513)
+ pbf (35446)
+ poly (35248)
+ reverter (35579)
+ undelete (35521)
+ utilsplugin2 (35597)

Last errors/warnings:
- 00007.178 W: Failed to delete outdated plugin '<josm.pref>\plugins\flatlaf.jar'.
- 00007.179 W: Failed to install already downloaded plugin 'flatlaf'. Skipping installation. JOSM is still going to load the old plugin version.
- 00025.528 E: Handled by bug report queue: org.openstreetmap.josm.tools.JosmRuntimeException: Fatal: failed to locate image '/colorchooser.???'. This is a serious configuration problem. JOSM will stop working.


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
org.openstreetmap.josm.tools.JosmRuntimeException: Fatal: failed to locate image '/colorchooser.???'. This is a serious configuration problem. JOSM will stop working.
	at org.openstreetmap.josm.tools.ImageProvider.getResource(ImageProvider.java:717)
	at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:655)
	at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:823)
	at org.openstreetmap.josm.gui.preferences.TabPreferenceSetting.getIcon(TabPreferenceSetting.java:33)
	at org.openstreetmap.josm.gui.preferences.PreferenceTabbedPane.addGUITabs(PreferenceTabbedPane.java:531)
	at org.openstreetmap.josm.gui.preferences.PreferenceTabbedPane.buildGui(PreferenceTabbedPane.java:492)
	at org.openstreetmap.josm.gui.preferences.PreferenceDialog.build(PreferenceDialog.java:86)
	at org.openstreetmap.josm.gui.preferences.PreferenceDialog.<init>(PreferenceDialog.java:56)
	at org.openstreetmap.josm.actions.PreferencesAction.run(PreferencesAction.java:109)
	at org.openstreetmap.josm.actions.PreferencesAction.actionPerformed(PreferencesAction.java:104)
	at javax.swing.SwingUtilities.notifyAction(SwingUtilities.java:1668)
	at javax.swing.JComponent.processKeyBinding(JComponent.java:2882)
	at javax.swing.KeyboardManager.fireBinding(KeyboardManager.java:307)
	at javax.swing.KeyboardManager.fireKeyboardAction(KeyboardManager.java:250)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(JComponent.java:2974)
	at javax.swing.JComponent.processKeyBindings(JComponent.java:2966)
	at javax.swing.JComponent.processKeyEvent(JComponent.java:2845)
	at java.awt.Component.processEvent(Component.java:6316)
	at java.awt.Container.processEvent(Container.java:2239)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2297)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1954)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:835)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:1103)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:974)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:800)
	at java.awt.Component.dispatchEventImpl(Component.java:4760)
	at java.awt.Container.dispatchEventImpl(Container.java:2297)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:760)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:84)
	at java.awt.EventQueue$4.run(EventQueue.java:733)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:730)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:205)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (7)

comment:1 Changed 10 days ago by GerdP

Cc: simon04 added
Description: modified (diff)

comment:2 Changed 10 days ago by GerdP

Priority: normalcritical

Happens also with a clean JOSM directory.

comment:3 Changed 10 days ago by skyper

regression of r17231.

comment:4 Changed 10 days ago by simon04

Resolution: fixed
Status: newclosed

In 17237/josm:

fix #19964 - Fix ColorPreference icon

comment:5 in reply to:  description Changed 10 days ago by skyper

Replying to GerdP:

 Last errors/warnings:
 - 00007.178 W: Failed to delete outdated plugin '<josm.pref>\plugins\flatlaf.jar'.
 - 00007.179 W: Failed to install already downloaded plugin 'flatlaf'. Skipping installation. JOSM is still going to load the old plugin version.

Looks like you also have a problem updating the flatlaf plugin, reported in #19901.

comment:6 Changed 10 days ago by GerdP

Not a problem for me, I just tried to reproduce the problem. I've already deleted the plugins.

BTW: The same icon can be found as core\resources\images\colorchooser.svg
Is that intended?

comment:7 Changed 10 days ago by Don-vip

Keywords: regression added
Milestone: 20.10

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.